Hi there,

I would like to compile a package with gcc/c++ 4.6 for SLES11 SP2 within OBS.

I tried to insert the following rules in the relate spec file:
Code:
...
BuildRequires: gcc46 gcc46-c++
...
%build
...
export CC=gcc-4.6
export CXX=g++-4.6
...
But this will result in an "unresolvable" status with the hint:
"conflict for provider of libgcc43, (provider libgcc43 is conflicted by installed libgcc46), conflict for provider of libgomp1 >= 4.6.20110701-0.13.9 needed by gcc46, (provider libgomp46 is conflicted by installed libgomp43)"

As suggested in another thread I set the Prefer statement in the project configuration file:
# osc meta prjconf -e
Code:
Prefer: gcc46
Prefer: gcc46-c++
Prefer: libgcc46
Prefer: libgomp46
But nothing is changed. Same "unresolvable" error.

In a stand-alone installation of SLES11 SP2 all is working fine after the installation of the complete gcc64 stack and removing the libgcc43.

Is there a way to force the use of gcc 4.6 on SLE_11_SP2 builds?


Best regards,
Ettore Simone