We upgraded Perl for some monitoring software "Pandora FMS (Flexible
Monitoring System)" we're trying to install and now many or most YaST
management tools don't function.

http://pandorafms.com/

Command used for the Perl upgrade was:
rpm -Uvh --force perl-5.12.3-11.14.1.x86_64.rpm --nodeps

For example, if I run the non-GUI "yast" and go to "Network Settings", I get
these errors.

Error loading language plugin /usr/lib64/YaST2/plugin/libpy2lang_perl.so:
libperl.so: cannot open shared object file: No such file or directory
Error loading language plugin /usr/lib64/YaST2/plugin/libpy2lang_perl.so:
libperl.so: cannot open shared object file: No such file or directory
Error while creating client module lan


Do you know if this can be fixed?

This SLES server's a VM so I can easily go to the server's state before the
perl upgrade.....in case someone has a better idea on how to upgrade Perl.

Thanks,
Marc