I recently installed SuSE Linux Enterprise Server 11 SP2 and have encountered a previously unencountered problem with YaST.

This server is being run only in text mode, which means that YaST is using ncurses for display functions. Following installation of SLES11 YaST was working fine. I had logged in on all six console screens and was using just one to run YaST. After finishing what I was doing in YaST I logged out on that console. Later on I logged in again (as root) and when I ran YaST to change something the display was filled with all sorts of garbage instead of the nice box graphics that would be expected. I exited from YaST and ran it on a different console screen that was already logged in. YaST displayed normally. I tried this in succession on the other console screens (all of which had been continuously logged in) and YaST was fine on them.

So I logged out on one screen where YaST was displaying properly and logged in again. This time YAST displayed the same corruption that had been seen on the other screen.

Something about logging out and then in again somehow corrupted the YaST display, but I haven't a clue what that might be. Has anyone here run into a similar problem and if so, what did you do to correct it?

Thanks!