We're migrating a group of SLES9 boxes, HP DL385/585 running as Oracle
servers, to SLES11 SP1. Also adding new HP BL460 G7 blades at the same
time. We've hit a major stumbling block when it comes to adding FC LUNs
on the fly from our EMC CX3-80 and new VNX 5500.

Previously, the steps were simple, totally reliable, non-disruptive,
and used hundreds of times:

echo "scsi-qlascan" > /proc/scsi/qla2xxx/0
echo "scsi-qlascan" > /proc/scsi/qla2xxx/1
rescan-scsi-bus.sh --luns=0-45 (or some appropriate number)
powermt config

It appears that this variant worked at one time for SLES11:

echo 1 > /sys/class/fc_host/host2/issue_lip
echo 1 > /sys/class/fc_host/host3/issue_lip
echo "- - -" > /sys/class/scsi_host/host2/scan
echo "- - -" > /sys/class/scsi_host/host3/scan
powermt config

And now it doesn't work for SLES11 SP1. Suse support provided a Qlogic
script that worked on 2 boxes and crashed a 3rd. And will not work on
the blade servers since they have the Emulex CNA. It was suggested that
the "rescan-scsi-bus.sh -i" should be all that is needed since it will
do a LIP to see the new LUNs. Does not work. We've tried this using both
mpio or Powerpath for multipathing. No difference. EMC documentation
for Emulex connectivity says that you must either reboot or reload FC
and scsi drivers.

Does anyone have an alternate method to non-disruptively rescan a FC
bus for new LUNs that works under SLES11 SP1 ??

thanks,
Don M.


--
tgic-systems
------------------------------------------------------------------------
tgic-systems's Profile: http://forums.novell.com/member.php?userid=66135
View this thread: http://forums.novell.com/showthread.php?t=446983