Hi

I have installed SUSE on my Aliemware m17r3 and I cannot get either of my networking cards to work.

uname -a
Linux alien 3.0.13-0.27-default #1 SMP Wed Feb 15 13:33:49 UTC 2012 (d73692b) x86_64 x86_64 x86_64 GNU/Linux

lspci
00:00.0 Host bridge: Intel Corporation 2nd Generation Core Processor Family DRAM Controller (rev 09)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200/2nd Generation Core Processor Family PCI Express Root Port (rev 09)
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
00:16.0 Communication controller: Intel Corporation 6 Series/C200 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2 (rev 05)
00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 05)
00:1c.0 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 1 (rev b5)
00:1c.2 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 3 (rev b5)
00:1c.3 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 4 (rev b5)
00:1c.5 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 6 (rev b5)
00:1d.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1 (rev 05)
00:1f.0 ISA bridge: Intel Corporation HM67 Express Chipset Family LPC Controller (rev 05)
00:1f.2 RAID bus controller: Intel Corporation 82801 Mobile SATA Controller [RAID mode] (rev 05)
00:1f.3 SMBus: Intel Corporation 6 Series/C200 Series Chipset Family SMBus Controller (rev 05)
01:00.0 VGA compatible controller: ATI Technologies Inc Broadway [ATI Mobility Radeon HD 6800 Series]
01:00.1 Audio device: ATI Technologies Inc Juniper HDMI Audio [Radeon HD 5700 Series]
07:00.0 Ethernet controller: Atheros Communications Inc. AR8151 v2.0 Gigabit Ethernet (rev c0)
0d:00.0 Network controller: Broadcom Corporation BCM4313 802.11b/g/n Wireless LAN Controller (rev 01)
13:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS5116 PCI Express Card Reader (rev 01)
13:00.1 SD Host controller: Realtek Semiconductor Co., Ltd. RTS5116 PCI Express Card Reader (rev 01)
19:00.0 USB controller: NEC Corporation uPD720200 USB 3.0 Host Controller (rev 04)

hwinfo --netcard
24: PCI 700.0: 0200 Ethernet controller
[Created at pci.323]
UDI: /org/freedesktop/Hal/devices/pci_1969_1083
Unique ID: aK5u.l+zm5Xmnr45
Parent ID: z8Q3.X+FUd6AcMZE
SysFS ID: /devices/pci0000:00/0000:00:1c.0/0000:07:00.0
SysFS BusID: 0000:07:00.0
Hardware Class: network
Model: "Atheros Ethernet controller"
Vendor: pci 0x1969 "Atheros Communications"
Device: pci 0x1083
SubVendor: pci 0x1028 "Dell"
SubDevice: pci 0x0490
Revision: 0xc0
Memory Range: 0xc7400000-0xc743ffff (rw,non-prefetchable)
I/O Ports: 0x4000-0x4fff (rw)
IRQ: 10 (no events)
Module Alias: "pci:v00001969d00001083sv00001028sd00000490bc02sc0 0i00"
Config Status: cfg=no, avail=yes, need=no, active=unknown
Attached to: #14 (PCI bridge)

25: PCI d00.0: 0280 Network controller
[Created at pci.323]
UDI: /org/freedesktop/Hal/devices/pci_14e4_4727
Unique ID: fSIl.jhn_u_Gejx4
Parent ID: hoOk.bf1UYOeQT50
SysFS ID: /devices/pci0000:00/0000:00:1c.2/0000:0d:00.0
SysFS BusID: 0000:0d:00.0
Hardware Class: network
Model: "Broadcom Network controller"
Vendor: pci 0x14e4 "Broadcom"
Device: pci 0x4727
SubVendor: pci 0x1028 "Dell"
SubDevice: pci 0x0010
Revision: 0x01
Memory Range: 0xc6400000-0xc6403fff (rw,non-prefetchable)
IRQ: 11 (no events)
Module Alias: "pci:v000014E4d00004727sv00001028sd00000010bc02sc8 0i00"
Config Status: cfg=no, avail=yes, need=no, active=unknown
Attached to: #15 (PCI bridge)

modinfo atl1e
filename: /lib/modules/3.0.13-0.27-default/kernel/drivers/net/atl1e/atl1e.ko
version: 1.0.0.7-NAPI
license: GPL
description: Atheros 1000M Ethernet Network Driver
author: Atheros Corporation, <xiong.huang@atheros.com>, Jie Yang <jie.yang@atheros.com>
srcversion: 8C54D44E579979EF1C2E599
alias: pci:v00001969d00001066sv*sd*bc*sc*i*
alias: pci:v00001969d00001026sv*sd*bc*sc*i*
depends:
supported: yes
vermagic: 3.0.13-0.27-default SMP mod_unload modversions
parm: tx_desc_cnt:Transmit description count (array of int)
parm: rx_mem_size:memory size of rx buffer(KB) (array of int)
parm: media_type:MediaType Select (array of int)
parm: int_mod_timer:Interrupt Moderator Timer (array of int)


when I do:

sudo depmod
sudo modprobe atl1e

lsmod finds it..

But
ifconfig eth0 up
eth0: unknown interface: No such device

and their is no wlan0 for the broadcom card either???

Where did I go wrong?