I'm having a devil of a time getting this install to work.

Specs are above, there are 6 600GB SAS drives in the machine, set as a RAID 5 container about 2.7TB large.

Initially, I tried to install SLES11, no service pack; that wouldn't see the drive during the partitioning stage of the install.

I'd tried two things at once, downloading and installing SLES11sp2 (going for the latest), and in the BIOS, enabling UEFI.
I was able to see the drives and create partitions after that, but I wasn't sure which change enabled it. Not knowing much about UEFI, and being under the gun timewise to get this server up and running, I rebooted it, disabled UEFI boot, and was still able to see the drive, create modify partitions, etc..

I made two partitions:

1) / is 65GB
2) 2 GB for swap. (The rest of the drive is reserved for future NSS volumes and currently unpartitioned)

I went ahead with the install, but at the bootloader install portion, it errored out.

grub >setup --stage2=/boot/grub/stage2 --force-lba (hd0.2) ...etc.
Checking if "/boot/grub/stage1" exists .. no
Checking if "/grub/stage1" exists .. no
Error 15: File not found
grub > quit


I didn't think I'd absolutely need UEFI and a GTP partition table since the partitions themselves are relatively small and everything here should support LBA48.

But perhaps I do? The whole UEFI and GTP thing is new to me.
This is the first we've ever tried using a raid container so large.

thanks..