I tried to install SLED 11 32-bit on a spare PC. After partitioning, it proceeds to install all the packages. Just after finishing this phase (the time remaining counter hit zero), the PC rebooted.
There should be a few more steps to configure after the package installations. I have installed various linux distros and this does not seem right to me.
It did not say please remove DVD or any warning such as "system must be rebooted to finalize". It looked like a sudden-death bug reboot.
The PC had Centos on it before, working with no problems. I then installed Ubuntu on it, and the install went without a hitch. I ran disk diagnostics and memory test. All good.
Then I tried the Firmware Test on the SLED install DVD. That came up with 3 fails:

Failed to locate HPET base
The memory map has a hole between 15 and 16 MB
Firmware not implementing hardware coordination cleanly

Are any of these serious? The PC is Dell with a BIOS locked down like a Stasi prison.
So should I just try again on another PC, and send this one to the recycling yard?