I have installed Xvfb and Firefox 8.0 on a headless server with SLES
11.

I have started Xvfb like
/usr/bin/Xvfb :7 -ac -screen 0 1024x768x8
I get the following error messages from Firefox:
[dix] Could not init font path element /usr/share/fonts/truetype/,
removing from list!
[dix] Could not init font path element /usr/share/fonts/TTF/, removing
from list!
[dix] Could not init font path element /usr/share/fonts/OTF, removing
from list!
[dix] Could not init font path element /usr/share/fonts/Type1/,
removing from list!
[dix] Could not init font path element
/usr/share/fonts/100dpi:unscaled, removing from list!
(EE) config/hal: NewInputDeviceRequest failed (2)
(EE) config/hal: NewInputDeviceRequest failed (2)
(EE) config/hal: NewInputDeviceRequest failed (2)
Xlib: extension "RANDR" missing on display ":7.0".
*** nss-shared-helper: Shared database disabled (set NSS_USE_SHARED_DB
to enable).

When I try to start Firefox with Selenium Server, I get the following
error:
15:29:40.771 ERROR [12]
org.openqa.selenium.server.BrowserSessionFactory - Failed to start new
browser session, shutdown browser and clear all session data
java.lang.RuntimeException: Timed out waiting for profile to be
created!
at
org.openqa.selenium.server.browserlaunchers.Firefo xChromeLauncher.waitForFullProfileToBeCreated(Fire foxChromeLauncher.java:364)
at
org.openqa.selenium.server.browserlaunchers.Firefo xChromeLauncher.populateCustomProfileDirectory(Fir efoxChromeLauncher.java:120)
at
org.openqa.selenium.server.browserlaunchers.Firefo xChromeLauncher.launch(FirefoxChromeLauncher.java: 90)
at
org.openqa.selenium.server.browserlaunchers.Firefo xChromeLauncher.launchRemoteSession(FirefoxChromeL auncher.java:416)
at
org.openqa.selenium.server.browserlaunchers.Firefo xLauncher.launchRemoteSession(FirefoxLauncher.java :118)
at
org.openqa.selenium.server.BrowserSessionFactory.c reateNewRemoteSession(BrowserSessionFactory.java:3 74)
at
org.openqa.selenium.server.BrowserSessionFactory.g etNewBrowserSession(BrowserSessionFactory.java:125 )
at
org.openqa.selenium.server.BrowserSessionFactory.g etNewBrowserSession(BrowserSessionFactory.java:86)
at
org.openqa.selenium.server.SeleniumDriverResourceH andler.getNewBrowserSession(SeleniumDriverResource Handler.java:809)
at
org.openqa.selenium.server.SeleniumDriverResourceH andler.doCommand(SeleniumDriverResourceHandler.jav a:435)
at
org.openqa.selenium.server.SeleniumDriverResourceH andler.handleCommandRequest(SeleniumDriverResource Handler.java:405)
at
org.openqa.selenium.server.SeleniumDriverResourceH andler.handle(SeleniumDriverResourceHandler.java:1 49)
at org.openqa.jetty.http.HttpContext.handle(HttpConte xt.java:1530)
at org.openqa.jetty.http.HttpContext.handle(HttpConte xt.java:1482)
at org.openqa.jetty.http.HttpServer.service(HttpServe r.java:909)
at
org.openqa.jetty.http.HttpConnection.service(HttpC onnection.java:820)
at
org.openqa.jetty.http.HttpConnection.handleNext(Ht tpConnection.java:986)
at
org.openqa.jetty.http.HttpConnection.handle(HttpCo nnection.java:837)
at
org.openqa.jetty.http.SocketListener.handleConnect ion(SocketListener.java:243)
at
org.openqa.jetty.util.ThreadedServer.handle(Thread edServer.java:357)
at
org.openqa.jetty.util.ThreadPool$PoolThread.run(Th readPool.java:534)
15:29:40.776 DEBUG [12]
org.openqa.selenium.server.FrameGroupCommandQueueS et - clearing queue
set
15:29:40.776 INFO [12]
org.openqa.selenium.server.SeleniumDriverResourceH andler - Got result:
Failed to start new browser session: Error while launching browser on
session null

I did not get the same Selenium error on Debian, so I suspect SLES 11
is different.


--
MattiLi
------------------------------------------------------------------------
MattiLi's Profile: http://forums.novell.com/member.php?userid=120388
View this thread: http://forums.novell.com/showthread.php?t=448780