Last weekend I decided to upgrade a XEN server with its 5 vm's. Unfortunately, after this action, I lost nss on an OES vm, and it transpired that the Novell Solution was to back rev the kernel due to a c-ck-p by themselves on the VM kernel. After putting this right, I then noticed that iSCSI was no longer functioning. The target computer is the XEN server, and the OES vm connects to 4TB of iSCSI disc on this XEN server. After a good deal of time wasted trying to fix the problem, I noticed that another Standalone backup server was also not connecting to a third 2tb iSCSI disc on this XEN server (the initiator being in this case a Windows 2008 r2 backup server). This pointed to the iSCSI not functioning correctly on the XEN machine after it was upgraded with the new latest XEN kernel. I then uninstalled the iSCSI software and re-installed it to hopefully correct any problems which may have appeared during the patch update cycle. This time, however, there appeared scripting problems with insserv during the install, although the administration console was now available under YAST.

If I tried to make an iSCSI connection to this server from another machine, I could establish a "connection", but not access any data, and get 100% utilization on the DOM0 of the XEN server. A short term solution has been to uninstall iSCSI on the XEN server, so all the vm's run at normal speed, and hope anyone here has a solution to resolving this issue. I have tried the re-installtion of iSCSI on the XEN target computer 4 times with the same insserv errors.

Hope someone has any pointers to get things working again.

Regards

ChasR.