Now that SLES11sp3 has been released I am unsure which repo's it should be associated to.
SLES11sp2 needs SLES11sp1 and SLES11sp2 repo's (http://www.novell.com/support/kb/doc.php?id=7010225)

I guess SLES11sp3 needs SLES11sp1, SLES11sp2 and SLES11sp3.

Can anyone confirm?