Hello together,

i have a question/problem with my SMT:

My fresh installed "SLES 11 SP3 for VMWare"-Machine, received its repositories (SLES11SP3Pool + SLES11SP3Updates) through suse_register, but the normal (non explicit VMWare-) SDK-Pool/Updates-Repos were missing. These SDK-Repos are already mirrored by SMT.

I have analysed the Product/Repository-Assignment with the command "smt-repos -m -o -v" and notice that the SDK-Repositories has no "SLES-for-VMware"-Productassignment within the SDK-Cataloge.

Actual:

Code:
[*] [ 34] SLE11-SDK-SP3-Pool sle-11-x86_64
          (SLE11-SDK-SP3-Pool for sle-11-x86_64)
          https://nu.novell.com/repo/$RCE/SLE11-SDK-SP3-Pool/sle-11-x86_64/
          $RCE/SLE11-SDK-SP3-Pool/sle-11-x86_64
          Repository ID: 79c841ecd628209e8e70d3a8e86845057791f22e
          Staging  : N
          Assigned to product: sle-sdk 11.3
          Assigned to product: sle-sdk-SP3-migration 11.2
Missing:
Code:
[*] [ 34] SLE11-SDK-SP3-Pool sle-11-x86_64
          (SLE11-SDK-SP3-Pool for sle-11-x86_64)
          https://nu.novell.com/repo/$RCE/SLE11-SDK-SP3-Pool/sle-11-x86_64/
          $RCE/SLE11-SDK-SP3-Pool/sle-11-x86_64
          Repository ID: 79c841ecd628209e8e70d3a8e86845057791f22e
          Staging  : N
          Assigned to product: sle-sdk 11.3
          Assigned to product: sle-sdk-SP3-migration 11.2
          Assigned to product: SLES-for-VMware 11.3
          Assigned to product: SLES-for-VMware-SP3-migration 11.2 x86_64
When i delete this catalog-entry and manual add this as "custom-repo" then the "LOCALPATH" (2nd Path below the Repo-Path http://...) changed to "RPMMD/...", because than it is no longer a default-Repo.

Is there any chance to add the missing product-assignment without handling with custom-repos?!

It would be nice, if you have a solution/tipp for me.
Thanks!