Results 1 to 4 of 4

Thread: Problem adding channels

Hybrid View

  1. #1

    Problem adding channels

    I've had an interesting time getting Suse Manager configured:
    Was having troubles registering Suse Manager with NCC through yast. It would say contacting server for a minute, then go back to the main yast screen. I finally had to run suse_register -i and complete the process interactively. Once that was done, I could do a zypper up.
    Now I'm attempting to add channels to suse manager. I run mgr-ncc-sync -l and get back
     Listing channels ...
    - P - channel is installed (provided)
    - . - channel is not installed, but is available
    - X - channel is not available
    [.] sles11-sp1-vmware-pool-i586
    [.] sles11-sp1-vmware-pool-x86_64
    [.] sles11-sp3-vmware-pool-i586
    [.] sles11-sp3-vmware-pool-x86_64
    I figure I should get more of those, but anyways, when I run mgr-ncc-sync -c sles11-sp1-vmware-pool-x86_64, I get:
    Traceback (most recent call last):
      File "/usr/sbin/mgr-ncc-sync", line 231, in <module>
      File "/usr/sbin/mgr-ncc-sync", line 99, in main
      File "/usr/lib64/python2.6/site-packages/spacewalk/susemanager/", line 1579, in add_channel
        self.map_channel_to_products(channel, channel_id, product_id)
      File "/usr/lib64/python2.6/site-packages/spacewalk/susemanager/", line 947, in map_channel_to_products
      File "/usr/lib64/python2.6/site-packages/spacewalk/server/rhnSQL/", line 156, in execute
        return self._execute_wrapper(self._execute, *p, **kw)
      File "/usr/lib64/python2.6/site-packages/spacewalk/server/rhnSQL/", line 287, in _execute_wrapper
        retval = function(*p, **kw)
      File "/usr/lib64/python2.6/site-packages/spacewalk/server/rhnSQL/", line 211, in _execute
        return self._execute_(args, kwargs)
      File "/usr/lib64/python2.6/site-packages/spacewalk/server/rhnSQL/", line 301, in _execute_
        self._real_cursor.execute(self.sql, params)
    psycopg2.ProgrammingError: column "channel_label" does not exist
    LINE 5:                    AND channel_label = E'sles11-sp1-vmware-p...
    So... should I be getting additional channels when running a list command. And how do I get past this psycopg2 error?

    Thanks much!

  2. Re: Problem adding channels

    Is your SUSE Manager server fully patched, *including* all database schema upgrades ? It seems as if the mgr-ncc-sync tool expects a different database schema.

  3. #3

    Re: Problem adding channels

    After posting my original message, I ran a schema upgrade, per the login window on suse manager, then ran mgr-ncc-sync -l, and saw the same channels listed. How can I tell if the server is fully patched?

    Thanks for the reply.

    edit: I added my sles11-sp1-vmware-pool-x86_64 channel successfully this time. Thanks very much. Should I be seeing more channels to add?
    Last edited by sysengPS; 17-Jul-2013 at 12:59.

  4. #4

    Re: Problem adding channels

    ok, so I was able to add a bunch of channels. Apparently, I needed to update my schema for all this to work. Thanks again for the post.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts