Hi there! I was just wondering how can I set up a Wlan based access point using the Suse's built in Master mode. I want to mention that, I have used Windows 2003 to do this in Ad-hoc mode, and it worked fine, but I need to "extend" the compatibility of my virtual access point.
I also want to mention that I have installed and configured DNS, DHCP, and the network interfaces (even DSL0)!
My O.S. is Suse Linux Enterprise Server 11 i586 with 2.6 kernel, and Wlan card tp-link wn350gd.

My configuration is something like this: eth0 as the (external zone in firewall, and WAN input, using static ip for initialization) (I use a PPPoE connection to access the Internet), dsl0 as my PPPoE provider connection (with dynamic ip, also external zone), eth1 as the ethernet output to the subnet clients (internal zone in firewall, but it's part of a network bridge so it has, wlan0 as the wireless adapter, configured in Master Mode, with WEP shared key, (the same as eth1, this is also internal zone in firewall, ip component of the bridge), and finally the Network Bridge between eth1 and wlan0, (this has a statically asigned ip like, this ip serves as DNS, Default Gateway, host address, etc...)

Problem: No Wireless connection on any laptop or device! On the other side of the situation the cable Internet eth0 works fine on the subnet workstations. I have also tried to set up my Wlan as Ad-hoc, but... nothing... At boot time something like this appears: Error for wireless request "Set Mode" (8B06) :
SET failed on device wlan0; (The Wlan card IS marked as COMPATIBLE with suse linux ) Invalid argument. an it says that the interface dosen't support IP. Somethimes it cannot de even bridged, an the same error persist for the Ad-hoc mode. I have read about Hostapd but it's hard to understand Linux language whe you sistematically use Windows It's evident why I use Suse graphically

Please help, Thanks in Advance!