I am attempting to install the package libssh2-1 on the one SuSe Enterprise 11 Server we have. However, I am encountering considerable difficulties. I have (finally) managed to get zypper to recognise the repository but now it refuses to install the package.

I give it the command:

# zypper install libssh2-1

New repository or package signing key received:
Key ID: B88B2FD43DBDC284
Key Name: openSUSE Project Signing Key <opensuse@opensuse.org>
Key Fingerprint: 22C07BA534178CD02EFE22AAB88B2FD43DBDC284
Repository: Live Media Builds (standard)

Do you want to reject the key, trust temporarily, or trust always? [r/t/a/?] (r): a
Building repository 'Live Media Builds (standard)' cache [done]
Loading repository data...
Reading installed packages...
'libssh2-1' not found.
Resolving package dependencies...

Nothing to do.


Obviously it hasn't installed the package. I have tried with other shorter and longer names and it still doesn't install it.

Can someone please tell me where I've gone wrong?