Results 1 to 9 of 9

Thread: TAPE BACKUP COMMAND - TAR for SLES11

Hybrid View

  1. #1
    ccilleperuma NNTP User

    TAPE BACKUP COMMAND - TAR for SLES11


    Hello,

    I am trying to take a backup on LTO 4 tape drive using SLES11. The
    command usage is "tar -cfz /dev/st0 /tape_test" where tape_test is the
    folder I need to backup.
    But it is giving following error.
    tar: Removing leading `/' from member names
    I searched the net for same error and found it is as a common error.
    But couldn't find a solution as they were not specific to solve my issue
    (LTO 4 tape on SLES 11).
    ex: 'Linux Tar Getting Removing Leading `/' From Member Names When
    Executed'
    (http://www.wallpaperama.com/forums/l...uted-t711.html)
    ex: 'tar: Removing leading `/ from member names | Skrakes.com'
    (http://www.skrakes.com/2009/09/11/ta...m-member-names)

    So I need help on resolving myne.
    Thanks in advance.

    C. C. Illeperuma


    --
    ccilleperuma
    ------------------------------------------------------------------------
    ccilleperuma's Profile: http://forums.novell.com/member.php?userid=97239
    View this thread: http://forums.novell.com/showthread.php?t=444974


  2. #2
    ab NNTP User

    Re: TAPE BACKUP COMMAND - TAR for SLES11

    -----BEGIN PGP SIGNED MESSAGE-----
    Hash: SHA1

    That's not an error... it's just a message telling you that because
    you're backing up something from the root of the filesystem that in the
    backup it's going to take that off. There is an --absolute-names option
    to override this if you REALLY want to, but I wouldn't recommend it.

    Good luck.


    - --
    Want to yell at me in person?
    Come to BrainShare 2011 in October: http://tinyurl.com/brainshare2011
    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v2.0.15 (GNU/Linux)
    Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

    iQIcBAEBAgAGBQJOeKIcAAoJEF+XTK08PnB5yEMQAJK30W6Lrg kEi9nPga74C/HL
    tMt7XVn3xUCDU7NQm70hiofRw/aHsivUFDo0XP+0ekJxiLOzYHwYtMoj7WJykxtm
    jc9yf5JfahCn/CgDg2WlWRfhmB8laEhtJ8xpdxHYN4bCG6cKcMVAKVETT9OClz0 Z
    5yLWwCjj60pOZLEZ75xSFVPwKRS8oQ7UIXkMVXnkwING6WU5oT 4FmLPhlPS6L5gg
    FzZv1bF/qlZLGHZHRbvsaJILxXO+uV9cQK8260OybhJgBWHHEFfZRWQ8Q3 HeU37J
    JJZZ1Z05gNvyttfbOaykKDny6oRPXxCdW5xIbAVCuwLkFbtMsl oQLHqqwz8W1f6i
    FLjZj4VDgwHcd/zGJmiCxBLS6EvbDBNOKYj+wL+2/zyCPYBaphPw/SZWPzyp1Dvo
    qkfIB/qjAd7Jo/bhd9e6k8ej1MohuVuXdxhnT0MJRyONRPksP2dp0znJv2RUfqkd
    3e/4cu+VgfBXOvgUR0EbtrqhRupWExXFu8aP2s2jgFO09mvnxYwZ1 3ZFEIEBjWww
    ZjYj37McELPzUFymnb9T/iebm8v+QotNpl7VhlxemqVtuMB3n2+9UqAH6QKXbHQJ
    ANZQAxgFTkTyod+Ci9oKYQhqa0/Ltcu4owq7wd9rDHA/SmU2E6iv9aTnDSo2HFn5
    wXfTSDQHtBXHAQQD1DDR
    =iVQf
    -----END PGP SIGNATURE-----

  3. #3
    ccilleperuma NNTP User

    Re: TAPE BACKUP COMMAND - TAR for SLES11


    Thanks ab. But when I try to confirm the backup it gives an error.


    Code:
    --------------------
    sapprdsvr:~ # mt -f /dev/st0 rewind
    sapprdsvr:~ # tar -cfz /dev/st0 /tape_test/
    tar: Removing leading `/' from member names
    sapprdsvr:~ # mt -f /dev/st0 status
    drive type = Generic SCSI-2 tape
    drive status = 1174405120
    sense key error = 0
    residue count = 0
    file number = 0
    block number = 0
    Tape block size 0 bytes. Density code 0x46 (unknown).
    Soft error count since last status=0
    General status bits on (41010000):
    BOT ONLINE IM_REP_EN
    sapprdsvr:~ # mt -f /dev/st0 tell
    mt: /dev/st0: Input/output error
    sapprdsvr:~ # mt -f /dev/st0 rewind
    sapprdsvr:~ # mt -f /dev/st0 status
    drive type = Generic SCSI-2 tape
    drive status = 1174405120
    sense key error = 0
    residue count = 0
    file number = 0
    block number = 0
    Tape block size 0 bytes. Density code 0x46 (unknown).
    Soft error count since last status=0
    General status bits on (41010000):
    BOT ONLINE IM_REP_EN
    sapprdsvr:~ # mt -f /dev/st0 tell
    mt: /dev/st0: Input/output error
    sapprdsvr:~ # tar -tzf /dev/st0
    tar (child): /dev/st0: Cannot read: Input/output error
    tar (child): At beginning of tape, quitting now
    tar (child): Error is not recoverable: exiting now

    gzip: stdin: unexpected end of file
    tar: Child returned status 2
    tar: Error is not recoverable: exiting now
    sapprdsvr:~ # cd /
    sapprdsvr:/ # tar -xzf /dev/st0 tape_test/
    tar (child): /dev/st0: Cannot read: Input/output error
    tar (child): At beginning of tape, quitting now
    tar (child): Error is not recoverable: exiting now

    gzip: stdin: unexpected end of file
    tar: Child returned status 2
    tar: Error is not recoverable: exiting now

    --------------------


    Is this because of mismatch block size? If so, How to overcome?
    Else, please guide me to troubleshoot it..

    Adding system log for more details..


    Code:
    --------------------
    Sep 21 09:27:28 sapprdsvr sshd[18114]: Accepted keyboard-interactive/pam for root from 192.168.51.75 port 49470 ssh2
    Sep 21 09:27:47 sapprdsvr kernel: [835191.723871] st0: Sense Key : Illegal Request [current]
    Sep 21 09:27:47 sapprdsvr kernel: [835191.723886] st0: Add. Sense: Invalid field in cdb
    Sep 21 09:30:01 sapprdsvr /usr/sbin/cron[18152]: (root) CMD ([ -x /usr/lib64/sa/sa1 ] && exec /usr/lib64/sa/sa1 -S ALL 1 1)
    Sep 21 09:31:44 sapprdsvr kernel: [835429.015562] st0: Sense Key : Illegal Request [current]
    Sep 21 09:31:44 sapprdsvr kernel: [835429.015577] st0: Add. Sense: Invalid field in cdb
    Sep 21 09:32:03 sapprdsvr kernel: [835448.319419] st0: Sense Key : Illegal Request [current]
    Sep 21 09:32:03 sapprdsvr kernel: [835448.319433] st0: Add. Sense: Invalid field in cdb
    Sep 21 09:40:01 sapprdsvr /usr/sbin/cron[18195]: (root) CMD ([ -x /usr/lib64/sa/sa1 ] && exec /usr/lib64/sa/sa1 -S ALL 1 1)
    Sep 21 09:40:33 sapprdsvr gnome-session[18224]: WARNING: GSIdleMonitor: IDLETIME counter not found
    Sep 21 09:40:33 sapprdsvr gnome-session[18224]: WARNING: Owner of /tmp/orbit-gdm is not the current user
    Sep 21 09:40:34 sapprdsvr pulseaudio[18252]: module.c: module-hal-detect is deprecated: Please use module-udev-detect instead of module-hal-detect!
    Sep 21 09:40:34 sapprdsvr gdm-simple-greeter[18247]: GLib-GObject-CRITICAL: g_param_spec_flags: assertion `G_TYPE_IS_FLAGS (flags_type)' failed
    Sep 21 09:40:34 sapprdsvr gdm-simple-greeter[18247]: GLib-GObject-CRITICAL: g_object_class_install_property: assertion `G_IS_PARAM_SPEC (pspec)' failed
    Sep 21 09:40:38 sapprdsvr gdm-session-worker[18248]: WARNING: gdm_session_settings_load: lang = (null)
    Sep 21 09:40:42 sapprdsvr gnome-session[18260]: WARNING: GSIdleMonitor: IDLETIME counter not found
    Sep 21 09:40:43 sapprdsvr gnome-keyring-daemon[18349]: adding removable location: volume_label_Feb_2011_LTO_GM at /media/Feb_2011_LTO_GM_
    Sep 21 09:40:43 sapprdsvr pulseaudio[18412]: pid.c: Stale PID file, overwriting.
    Sep 21 09:40:43 sapprdsvr pulseaudio[18412]: module.c: module-hal-detect is deprecated: Please use module-udev-detect instead of module-hal-detect!
    --------------------



    Thanks,

    C. C. Illeperuma


    --
    ccilleperuma
    ------------------------------------------------------------------------
    ccilleperuma's Profile: http://forums.novell.com/member.php?userid=97239
    View this thread: http://forums.novell.com/showthread.php?t=444974


  4. #4
    ab NNTP User

    Re: TAPE BACKUP COMMAND - TAR for SLES11

    -----BEGIN PGP SIGNED MESSAGE-----
    Hash: SHA1

    Your errors make me think your tape drive is not happy. I assume the
    tar commands work with regular (non-tape) files... correct? If so, fix
    your tape. Having never really worked with one I can't help with that.

    Good luck.


    - --
    Want to yell at me in person?
    Come to BrainShare 2011 in October: http://tinyurl.com/brainshare2011
    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v2.0.15 (GNU/Linux)
    Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

    iQIcBAEBAgAGBQJOeXCAAAoJEF+XTK08PnB5KAEP/ib3Jvkp/883WWQhQf30I+bv
    p7d5z3gANpr2lfOHk/ky8JvHO2Mz6M+xiOVELtnYfuiRSDlR2fBVWtanst8U62Bm
    dHT77QOVKwv3/9S1sC+sdpxx1GhNDEgGaP1zryGUnQ2Crvht2sN4KVQ4GcAFHCJ X
    8l/8edNP/u68x3fdaDJm3vJwxoY/OmKbo2Gxl7u0yiU4kaCQ1gCiDnj/N5xJoc0L
    kqodMwfC0li02PekmqELTG4cHGsp/5MCZPnxLg5wvF1Jt4/33OgMARPasfbdFQkC
    9mA3tt2XQMMB81jvnMWlXv7RUUMq9gj6YyVWL88V1f1S1selhH el/rbFtAs1WW6h
    c2IhOo6lM75U89bhsUj6Jla1P3bpUxs8uaAHEL73qbSM8YqTr3 3ctZDfnxqjbNzW
    paPh9gacYhB3xzOKnEcAFxfcGwq4JJBgNGar0BoKv7th4tD9Ps LqIDCeskOsPgtT
    DWqhR2O1YJM/sZEW+G9QsUOpR9FUTPcDhC+8jxfHi4NGumovT4x2SkaorXH5BM +e
    /uQH73WXTTToE7vdCXoXphZAyTPa4qk+yKu8fDLoDSKrQrEJfC5 g4MI8OCsDVIYv
    vGz5jf2zPc0CLWvL7G+Y9agcGtDZP+LimLbZ/pXw4QpPK56DuYtGc0PdjjdAXMQl
    OmLJGVMvqjXXlysBDBDv
    =UoN0
    -----END PGP SIGNATURE-----

  5. #5
    ccilleperuma NNTP User

    Re: TAPE BACKUP COMMAND - TAR for SLES11


    Thanks ab,

    Is there anyone who can guide me to solve this?

    Regards,

    C. C. Illeperuma


    --
    ccilleperuma
    ------------------------------------------------------------------------
    ccilleperuma's Profile: http://forums.novell.com/member.php?userid=97239
    View this thread: http://forums.novell.com/showthread.php?t=444974


  6. #6
    malcolmlewis NNTP User

    Re: TAPE BACKUP COMMAND - TAR for SLES11

    On Wed, 21 Sep 2011 08:26:02 GMT
    ccilleperuma <ccilleperuma@no-mx.forums.novell.com> wrote:

    >
    > Thanks ab,
    >
    > Is there anyone who can guide me to solve this?
    >
    > Regards,
    >
    > C. C. Illeperuma
    >
    >

    Hi
    Do you have a tape cleaner cartridge, suggest you run that. Are the
    tapes old/new?

    --
    Cheers Malcolm °¿° (Linux Counter #276890)
    openSUSE 11.4 (x86_64) Kernel 2.6.37.6-0.7-desktop
    up 8 days 14:41, 3 users, load average: 0.23, 0.20, 0.15
    GPU GeForce 8600 GTS Silent - Driver Version: 280.13


  7. #7
    ccilleperuma NNTP User

    Re: TAPE BACKUP COMMAND - TAR for SLES11


    I cleaned the tape drive, but the issue is still the same.
    Tapes are all new.
    Can you please share the tape backup restore command here?

    C. C. Illeperuma


    --
    ccilleperuma
    ------------------------------------------------------------------------
    ccilleperuma's Profile: http://forums.novell.com/member.php?userid=97239
    View this thread: http://forums.novell.com/showthread.php?t=444974


  8. #8
    malcolmlewis NNTP User

    Re: TAPE BACKUP COMMAND - TAR for SLES11

    On Fri, 23 Sep 2011 06:26:02 GMT
    ccilleperuma <ccilleperuma@no-mx.forums.novell.com> wrote:

    >
    > I cleaned the tape drive, but the issue is still the same.
    > Tapes are all new.
    > Can you please share the tape backup restore command here?
    >
    > C. C. Illeperuma
    >
    >

    Hi
    As ab pointed out it maybe the tape drive on the way out.

    (Needs to go find a SCSI card and tape drive in storage....)

    --
    Cheers Malcolm °¿° (Linux Counter #276890)
    openSUSE 11.4 (x86_64) Kernel 2.6.37.6-0.7-desktop
    up 16:37, 3 users, load average: 0.12, 0.13, 0.14
    GPU GeForce 8600 GTS Silent - Driver Version: 280.13


  9. #9
    ccilleperuma NNTP User

    Re: TAPE BACKUP COMMAND - TAR for SLES11


    Thanks malcolmlewis,

    I found the issue. It was not with Tape drive hardware, but with my
    command.
    All ok when I go to a location where I extract the files from tape "tar
    -xzf /dev/st0"
    Before I was trying to give the restoration file name after the above
    command.

    ccilleperuma


    --
    ccilleperuma
    ------------------------------------------------------------------------
    ccilleperuma's Profile: http://forums.novell.com/member.php?userid=97239
    View this thread: http://forums.novell.com/showthread.php?t=444974


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •