we use studio onsite in combination with suse lifecycle management server to build and to manage lots of virtual appliances (mostly xen-images based on SLES SP1).
Since we managed to serve SP2-based templates the button "SLES 11 SP2 is now available Upgrade" appears in the welcome-screens of all our SP1-based Appliances and now we want to upgrade all our sp1-based, adapted and rolled-out, productive appliance-instances to service pack 2!

The procedure for maintenance-updates was in short:
- Refresh Appliances from Studio in SLMS (automatic)
- SLMS then notices existence of new updates for the appliances
- generate patch (qa, publish ...)
- login to every appliance-instance
- run zypper ref and zypper up to install maintenance updates

For SP-Upgrade we tried the following:
- Press Upgrade-Button in Studio (Studio then notices us about adding SP2-Repositories and a handfull of new packages)
- Refresh Appliance from Studio in SLMS
- generate Patch
- login to appliance-instance
- run zypper ref and zypper up

Zypper installed a few new packages and updates but the upgrade was not done. We tried 'zypper dup' on the appliance instance and there was only one package to update.
/etc/SuSE-release still shows SP1 so we think the upgrade was not done correctly.

Since there ist now SLMS-Forum, i posted this issue here. I hope that is ok.
We still use Studio and SLMS in Version 1.2

Let me know, if you need some more or more specific informations about our environment.
Any help would be appreciated.