Hello,

I'm creating an xml file template to do automatic installation (which packages to install, security settings, network config, etc).

Only hostname/ip adress/netmask/route/domain are request via windows popups.
After filling in all the questions, the system boots with all network informations except gateway, and the hosts file that is not filled in correctly.

Meaning in file /etc/sysconfig/network/routes, there is not the wanted ip adress, but $gateway,
and in /etc/hosts, this is 127.0.0.2 toto.titi.fr toto
instdead of good ip adress (fqdn and localhosthame are ok).

in the xml file :

<hosts> part contains this :
</hosts_entry>
#set $ikeys = $interfaces.keys()
#for $iface in $ikeys
#set $idata = $interfaces[$iface]
#if $idata["interface_type"].lower() in ["","na","bridge","bond"]
<hosts_entry>
<host_address>$idata["ip_address"]</host_address>
<names config:type="list">
<name>$idata["dns_name"].lower() $my_interface_hostname_short.lower()</name>
</names>
</hosts_entry>

and question is like this

<listentry>
<element config:type="integer">4</element>
<file>/tmp/gateway.txt</file>
<pathlist config:type="list">
<title>gateway</title>
<path>networking,routing,routes,1,gateway</path>
</pathlist>
<question>Enter default IPv4 gateway</question>
<stage>initial</stage>
</listentry>

for /etc/sysconfig/network/routes, the xml contains this :

<routes config:type="list">
<route>
<destination>default</destination>
<device>-</device>
<netmask>-</netmask>
<gateway>$gateway</gateway>
</route>
</routes>

Can you help me to correct this ? if don't find any documentations regarding functions/arguments/variables

Thank you