I am facing exactly the same issue which insyen has mentioned here.. Even after struggling a lot i found nothing helpful.
I tried to Use Repair Tool option - "Install New Boot Loader" and then tried to load boot loader using option - "Boot Installed system". It is displaying message "No Linux Root Partition Found" even though i have explicitly created root partition.

My Hard disk size is 1TB and i am also doing the fresh installation, everything gone proper but after installation it is not starting or either displaying Booth menu.

I have created new partitions this way

Device Size Type FS Type Mount Point Start end
---------- ---------- ---------- ---------- ---------- ---------- ----------
/dev/sda 931.51GB ST1000DM003 0 121600
/dev/sda1 10.51GB win95 Fat32 LBA Fat /boot/init 0 1371
/dev/sda2 8GB Linux Swap Swap Swap 1371 2416
/dev/sda3 250GB Linux Native Ext3 / 2416 35050
/dev/sda4 250GB Linux Native Ext3 /FS001 35050 67088
/dev/sda5 212.99GB Linux Native Ext3 /FS002 67088 95491
/dev/sda6 200.01GB Linux Native Ext3 /FS003 95491 121600

But after first reboot when i rechecked my partition details then it shows columns as above except "Mount Point".. Mount point field is disabled.. What exactly is happening?
I think thats why it is not able to find root partition for loading.

Awaiting your positive feedback.

@insyen: Are you getting the same thing which your installation?

Also please suggest me the partition which i have created in proper or not.