I'm trying to use autoyast to manage the installation of some SLED 11 SP3 boxes using UEFI, as they each have a couple of 3TB disks in them.

It's all going swimmingly except for one thing: I can't work out how to get the routine to create an EFI bootmanager entry, so the installation fails to boot after the first stage.

If I set autoyast to pause before going ahead with the installation, and select the Expert tab and look under the Boot Loader section it reads "Do not create an EFI bootmanager entry." If I go into the Boot Loader section to modify it, I can't find anything that looks like it might alter this behaviour. Unsurprisingly, using YaST's autoinstallation tool to edit my control file also shows the section being set to not create the entry, but again I can't find anything that looks like it will change this setting.

If, instead of using autoyast, I just boot the machine off a SLED installation DVD and look at the Boot Loader section on the Expert tab, it says "Create an EFI bootmanager entry."

I can't find any mention of how to modify this setting in the Autoyast documentation either. Have I completely misunderstood this, or something? If I use a repair mid-installation to fix the problem with the bootloader, it'll carry on and install fine...

David