(actually.. I don't know where to find it...)

SUSE Linux Enterprise Server 11 (i586)


Hi,

I need to get an Eclipse C++ up and running on my SUSE Linux Enterprise Server 11 (i586)

Eclipse install went well, but I can't get the gcc-c++ compiler installed..




Just to see what is there:


susehost:~ # rpm -q gcc
gcc-4.3-62.198
susehost:~ # rpm -q gcc-c++
package gcc-c++ is not installed
susehost:~ #

Went to YaST2 Software Management where found "gcc-c++"


The system GNU C++ Compiler"
Install failed.. it tried to find the install on CDRom Drive

Tried zypper


Same story, no media:

susehost:~ # zypper install gcc-c++
Loading repository data...
Reading installed packages...
Resolving package dependencies...

The following NEW packages are going to be installed:
gcc43-c++ gcc-c++

Overall download size: 3.0 M. After the operation, additional 7.9 M will be used. (<<< download from where??)
Continue? [YES/no]: YES
Retrieving package gcc43-c++-4.3.3_20081022-11.18.i586 (1/2), 3.0 M (7.9 M unpacked)
Failed to mount cd:///?devices=/dev/sr0 on /var/adm/mount/AP_0x00000001: No medium found (mount: No medium found on /dev/sr0)

Abort, retry, ignore? [A/r/i]:

Found the gcc-c++.ymp on software.opensuse.org..


did download.. but no clue was found how to install that image.

Long story short..

Obviously, I have no install media..
I need to find a way to change media from /dev/sr0 to internet.. I found that in Yast, Software, Software repositories where I could see the /dev/sr0, and I can add a line..
HTTP, HTTPS, FTP.. etc.. but where do I go?? It needs repository name..Server name.. Directory on server Where is my "gcc-c++" ??


Many thanks,
Adzy