I've been trying to solve a problem I though was trivial, but after 2 days I'm nearing the point of desperation. I have SLES 11 SP2 running on an IBM Server x3200, enough power, RAM , disc space and compatibility is not a problem. Everything was running smoothly until a few days ago when I was trying to get a GUI remotely from my desktop using the "forwarding X11". I changed a couple of entries in the ssh and sshd config files because I know this is a security issue (I've done this before and it worked but couldn't remember what I did exactly).

I can access the Server per ssh remotely as well as locally on the command line, when I try to login through the GUI, the user and password is accepted, screen disappears and reappears! This happens over and over (user and pw are correct) and I just can't get the gnome to load properely. I've searched countless forums using well known search engines with key words from the logs and have tried out a lot of stuff but nothing seems to work. One idea was a graphic card issue which I find strange because I didn't change anything there. I tried running sax2 -r in runlevel 3 modus, readjusted the settings but that didn't help.

This is what I found in /var/log/messages:
kernel: [10629.143358] pci 0000:07:00.0: Invalid ROM contents
kernel: [10629.143360] pci 0000:07:00.0: Invalid ROM contents
gdm-simple-greeter[29536]: GLib-GObject-CRITICAL: g_param_spec_flags: assertion `G_TYPE_IS_FLAGS (flags_type)' failed
gdm-simple-greeter[29536]: GLib-GObject-CRITICAL: g_object_class_install_property: assertion `G_IS_PARAM_SPEC (pspec)' failed

this also looks fishy but doesn't tell me much...

gdm-session-worker[26956]: WARNING: gdm_session_settings_load: lang = (null)
checkproc: checkproc: can not get session id for process 26842!

These are the contents of ~/.xsession-errors (which keep coming up each time I try to login)

/etc/X11/xim: Checking whether an input method should be started.
/etc/X11/xim: use GDM_LANG=de_DE.UTF-8
sourcing /etc/sysconfig/language to get the value of INPUT_METHOD
INPUT_METHOD is not set or empty (no user selected input method).
Trying to start a default input method for the locale de_DE.UTF-8 ...
There is no default input method for the current locale.
Dummy input method "none" (do not use any fancy input method by default)
No protocol specified
No protocol specified

** (gnome-session:29327): WARNING **: Anzeige kann nicht geöffnet werden: (TRANSLATION: Display cannot be opned)

Would really appreciate any help I could get here. As mentioned above, everything was working fine till I started fiddling with the X-server settings, I have changed all of them back to the old values as far as I can tell. I don't really want to do a windows solution by re-installing everything, that would mean a lot of work getting everything back to where I had it. Help!