I'm bumping this back to the top. I still can't seem to figure out how
to get vsftpd configured so files get uploaded with the permissions I
want. Things have changed a bit since I started this thread nearly a
year ago. I need users (not virtual) to be able to upload directories to
a Web server, and those directories should have permissions of 775. I
have the sticky bit enabled on the parent directory so the group is

I changed the config file to have a umask value of 0002:


Yet if I upload a directory it still has permissions of 755. I don't

boy412's Profile: http://forums.novell.com/member.php?userid=102125
View this thread: http://forums.novell.com/showthread.php?t=429593