Results 1 to 16 of 16

Thread: Repo Import failed

  1. #1
    LycheeLinux NNTP User

    Repo Import failed


    I am trying to import my repo I am hosting on my server.
    I can add my repository simply with: sudo zypper ar -f URL ALIAS
    or sudo zypper ar -r URL/file.repo
    on openSUSE but I cannot add it in SuseStudio.
    It says: Importing the repository '' () failed:
    Where is the problem?


    --
    LycheeLinux
    ------------------------------------------------------------------------
    LycheeLinux's Profile: http://forums.opensuse.org/member.php?userid=80497
    View this thread: http://forums.opensuse.org/showthread.php?t=495199


  2. Re: Repo Import failed

    On Thu, 06 Feb 2014 00:46:01 +0000, LycheeLinux wrote:

    > I am trying to import my repo I am hosting on my server.
    > I can add my repository simply with: sudo zypper ar -f URL ALIAS or sudo
    > zypper ar -r URL/file.repo on openSUSE but I cannot add it in
    > SuseStudio.
    > It says: Importing the repository '' () failed:
    > Where is the problem?


    Where is your server located? ie, is it behind a firewall? If so, is
    port forwarding enabled to get the connection to your server?

    Jim



    --
    Jim Henderson, CNA6, CDE, CNI, LPIC-1, CLA10, CLP10
    Novell/SUSE/NetIQ Knowledge Partner

  3. #3
    LycheeLinux NNTP User

    Re: Repo Import failed


    My Repo is on my public server where I am also hosting my website. I can
    browse through the repo and add it in opensuse manually. Why should I
    need portforwarding then? If this would be the problem I should not be
    able to add it manually too.

    Jim Henderson;2622430 Wrote:
    > On Thu, 06 Feb 2014 00:46:01 +0000, LycheeLinux wrote:
    >
    > > I am trying to import my repo I am hosting on my server.
    > > I can add my repository simply with: sudo zypper ar -f URL ALIAS or

    > sudo
    > > zypper ar -r URL/file.repo on openSUSE but I cannot add it in
    > > SuseStudio.
    > > It says: Importing the repository '' () failed:
    > > Where is the problem?

    >
    > Where is your server located? ie, is it behind a firewall? If so, is
    > port forwarding enabled to get the connection to your server?
    >
    > Jim
    >
    >
    >
    > --
    > Jim Henderson, CNA6, CDE, CNI, LPIC-1, CLA10, CLP10
    > Novell/SUSE/NetIQ Knowledge Partner



    --
    LycheeLinux
    ------------------------------------------------------------------------
    LycheeLinux's Profile: http://forums.opensuse.org/member.php?userid=80497
    View this thread: http://forums.opensuse.org/showthread.php?t=495199


  4. Re: Repo Import failed

    On Thu, 06 Feb 2014 10:06:02 +0000, LycheeLinux wrote:

    > My Repo is on my public server where I am also hosting my website. I can
    > browse through the repo and add it in opensuse manually. Why should I
    > need portforwarding then? If this would be the problem I should not be
    > able to add it manually too.


    There are a number of ways to set up a repo server, and if you're behind
    a firewall, that would explain why it's not importing properly, so I
    wanted to eliminate that.

    Since that's not the issue, we'll need more information about how the repo
    is set up and its connectivity in order to provide further assistance.

    Jim
    --
    Jim Henderson, CNA6, CDE, CNI, LPIC-1, CLA10, CLP10
    Novell/SUSE/NetIQ Knowledge Partner

  5. #5
    LycheeLinux NNTP User

    Re: Repo Import failed


    The Url is repo.lycheelinux.com.
    I created it locally on my computer and uploaded it with rsync to the
    server.

    Jim Henderson;2622515 Wrote:
    > On Thu, 06 Feb 2014 10:06:02 +0000, LycheeLinux wrote:
    >
    > > My Repo is on my public server where I am also hosting my website. I

    > can
    > > browse through the repo and add it in opensuse manually. Why should I
    > > need portforwarding then? If this would be the problem I should not be
    > > able to add it manually too.

    >
    > There are a number of ways to set up a repo server, and if you're behind
    > a firewall, that would explain why it's not importing properly, so I
    > wanted to eliminate that.
    >
    > Since that's not the issue, we'll need more information about how the
    > repo
    > is set up and its connectivity in order to provide further assistance.
    >
    >
    > Jim
    > --
    > Jim Henderson, CNA6, CDE, CNI, LPIC-1, CLA10, CLP10
    > Novell/SUSE/NetIQ Knowledge Partner



    --
    LycheeLinux
    ------------------------------------------------------------------------
    LycheeLinux's Profile: http://forums.opensuse.org/member.php?userid=80497
    View this thread: http://forums.opensuse.org/showthread.php?t=495199


  6. Re: Repo Import failed

    On Thu, 06 Feb 2014 16:36:01 +0000, LycheeLinux wrote:

    > The Url is repo.lycheelinux.com.
    > I created it locally on my computer and uploaded it with rsync to the
    > server.


    In looking at the import, it looks like you need to supply the path to
    the root of the repo rather than the path to the .repo file.

    I tried that and it seems to start, but then it throws an error as well -
    but it looks like something they'll need to look at on the backend. If
    you click the "Forum" link at the bottom of susestudio.com (when logged
    in), that'll get your question to the right people.

    Jim

    --
    Jim Henderson, CNA6, CDE, CNI, LPIC-1, CLA10, CLP10
    Novell/SUSE/NetIQ Knowledge Partner

  7. #7
    LycheeLinux NNTP User

    Re: Repo Import failed


    So what would you change exactly?

    I already posted it there but I dont get any response.
    Jim Henderson;2622596 Wrote:
    > On Thu, 06 Feb 2014 16:36:01 +0000, LycheeLinux wrote:
    >
    > > The Url is repo.lycheelinux.com.
    > > I created it locally on my computer and uploaded it with rsync to the
    > > server.

    >
    > In looking at the import, it looks like you need to supply the path to
    > the root of the repo rather than the path to the .repo file.
    >
    > I tried that and it seems to start, but then it throws an error as well
    > -
    > but it looks like something they'll need to look at on the backend. If
    > you click the "Forum" link at the bottom of susestudio.com (when logged
    > in), that'll get your question to the right people.
    >
    > Jim
    >
    > --
    > Jim Henderson, CNA6, CDE, CNI, LPIC-1, CLA10, CLP10
    > Novell/SUSE/NetIQ Knowledge Partner



    --
    LycheeLinux
    ------------------------------------------------------------------------
    LycheeLinux's Profile: http://forums.opensuse.org/member.php?userid=80497
    View this thread: http://forums.opensuse.org/showthread.php?t=495199


  8. Re: Repo Import failed

    On Thu, 06 Feb 2014 23:06:01 +0000, LycheeLinux wrote:

    > So what would you change exactly?


    The URL. http://repo.lycheelinux.com is what you should use, leave off
    the /[file].repo part of it, as it's not needed.

    > I already posted it there but I dont get any response.


    Let me see if I can poke someone, as the URL that you should use doesn't
    seem to be working either.

    Jim


    --
    Jim Henderson, CNA6, CDE, CNI, LPIC-1, CLA10, CLP10
    Novell/SUSE/NetIQ Knowledge Partner

  9. Re: Repo Import failed

    On Thu 06 Feb 2014 11:06:01 PM CST, LycheeLinux wrote:


    So what would you change exactly?

    I already posted it there but I dont get any response.
    Jim Henderson;2622596 Wrote:
    > On Thu, 06 Feb 2014 16:36:01 +0000, LycheeLinux wrote:
    >
    > > The Url is repo.lycheelinux.com.
    > > I created it locally on my computer and uploaded it with rsync to
    > > the server.

    >
    > In looking at the import, it looks like you need to supply the path to
    > the root of the repo rather than the path to the .repo file.
    >
    > I tried that and it seems to start, but then it throws an error as
    > well -
    > but it looks like something they'll need to look at on the backend.
    > If you click the "Forum" link at the bottom of susestudio.com (when
    > logged in), that'll get your question to the right people.
    >
    > Jim
    >
    > --
    > Jim Henderson, CNA6, CDE, CNI, LPIC-1, CLA10, CLP10
    > Novell/SUSE/NetIQ Knowledge Partner



    Hi
    Why host something that can already be added direct from OBS into SUSE
    Studio? For random rpm's, just upload them?

    Owncloud use OBS directly to create all there rpms etc for distribution.

    --
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    openSUSE 13.1 (Bottle) (x86_64) GNOME 3.10.2 Kernel 3.11.6-4-desktop
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!


  10. #10
    LycheeLinux NNTP User

    Re: Repo Import failed


    I already tried it without the .repo file.
    Thanks.

    I just uploaded some test packages. It is much nicer for me to have my
    own repository.


    --
    LycheeLinux
    ------------------------------------------------------------------------
    LycheeLinux's Profile: http://forums.opensuse.org/member.php?userid=80497
    View this thread: http://forums.opensuse.org/showthread.php?t=495199


  11. Re: Repo Import failed

    On Fri, 07 Feb 2014 12:56:02 +0000, LycheeLinux wrote:

    > I already tried it without the .repo file.


    You hadn't mentioned that - not sure how we were supposed to know that
    without you telling us that.

    Is there any other information - things you've tried, etc - that you
    might be assuming we know?

    Jim
    --
    Jim Henderson, CNA6, CDE, CNI, LPIC-1, CLA10, CLP10
    Novell/SUSE/NetIQ Knowledge Partner

  12. #12
    LycheeLinux NNTP User

    Re: Repo Import failed


    Sorry I tried also signed and unsigned. Nothing more I think.
    I works with yum and zypper in opensuse but not in SUSEStudio.

    Jim Henderson;2622886 Wrote:
    > On Fri, 07 Feb 2014 12:56:02 +0000, LycheeLinux wrote:
    >
    > > I already tried it without the .repo file.

    >
    > You hadn't mentioned that - not sure how we were supposed to know that
    > without you telling us that.
    >
    > Is there any other information - things you've tried, etc - that you
    > might be assuming we know?
    >
    > Jim
    > --
    > Jim Henderson, CNA6, CDE, CNI, LPIC-1, CLA10, CLP10
    > Novell/SUSE/NetIQ Knowledge Partner



    --
    LycheeLinux
    ------------------------------------------------------------------------
    LycheeLinux's Profile: http://forums.opensuse.org/member.php?userid=80497
    View this thread: http://forums.opensuse.org/showthread.php?t=495199


  13. Re: Repo Import failed

    On Sat, 08 Feb 2014 16:56:02 +0000, LycheeLinux wrote:

    > Sorry I tried also signed and unsigned. Nothing more I think. I works
    > with yum and zypper in opensuse but not in SUSEStudio.


    I've asked that someone poke the person who's supposed to be monitoring
    the mailing list/forum for Studio, so hopefully you'll get an answer over
    there shortly. To diagnose this requires (I think) someone on the backend
    to look and see what error's being generated there.

    Jim
    --
    Jim Henderson, CNA6, CDE, CNI, LPIC-1, CLA10, CLP10
    Novell/SUSE/NetIQ Knowledge Partner

  14. #14
    LycheeLinux NNTP User

    Re: Repo Import failed


    Thanks Yeah the error which is displayed is not really helping me

    Jim Henderson;2623244 Wrote:
    > On Sat, 08 Feb 2014 16:56:02 +0000, LycheeLinux wrote:
    >
    > > Sorry I tried also signed and unsigned. Nothing more I think. I works
    > > with yum and zypper in opensuse but not in SUSEStudio.

    >
    > I've asked that someone poke the person who's supposed to be monitoring
    > the mailing list/forum for Studio, so hopefully you'll get an answer
    > over
    > there shortly. To diagnose this requires (I think) someone on the
    > backend
    > to look and see what error's being generated there.
    >
    > Jim
    > --
    > Jim Henderson, CNA6, CDE, CNI, LPIC-1, CLA10, CLP10
    > Novell/SUSE/NetIQ Knowledge Partner



    --
    LycheeLinux
    ------------------------------------------------------------------------
    LycheeLinux's Profile: http://forums.opensuse.org/member.php?userid=80497
    View this thread: http://forums.opensuse.org/showthread.php?t=495199


  15. #15
    LycheeLinux NNTP User

    Re: Repo Import failed


    I have not been contacted in any way yet?
    LycheeLinux;2623255 Wrote:
    > Thanks Yeah the error which is displayed is not really helping me



    --
    LycheeLinux
    ------------------------------------------------------------------------
    LycheeLinux's Profile: http://forums.opensuse.org/member.php?userid=80497
    View this thread: http://forums.opensuse.org/showthread.php?t=495199


  16. Re: Repo Import failed

    On Sun, 16 Feb 2014 22:36:02 +0000, LycheeLinux wrote:

    > I have not been contacted in any way yet?
    > LycheeLinux;2623255 Wrote:
    >> Thanks Yeah the error which is displayed is not really helping me


    Try posting to that list again (the "forum" link on the SUSE Studio
    site). Might be that they couldn't find the post easily.

    Jim



    --
    Jim Henderson, CNA6, CDE, CNI, LPIC-1, CLA10, CLP10
    Novell/SUSE/NetIQ Knowledge Partner

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •