Results 1 to 2 of 2

Thread: SLES 12 installation with secure boot - drop to grub2 shell

Hybrid View

  1. #1

    Wink SLES 12 installation with secure boot - drop to grub2 shell

    Hello,

    I just tried SLES 12 beta2 installation on our x86_64 machine. I enroll the shim-sles.der certificate so that I can proceed the full installation with secure boot enabled.

    After the installation, the system reboots normally. But it drops into grub2 shell: grub>

    After some investigation, I found that this "grub2" can't find its configfile. Because once I specify it manually as
    grub> configfile (hd1,gpt3)/@/boot/grub2/grub.cfg

    The grub menu pops normally and I can boot into SLES without problems (with secure boot enabled!!).

    The strange point is the grub2's root path includes an extra '@' symbol after the root path. Check this:
    grub>ls (hd1,gpt3)/
    @/

    grub>ls (hd1,gpt3)/@
    dev/ run/ selinux/ boot/ lib/ ......

    grub>set
    ....
    prefix=(hd1,gpt3)/boot/grub2
    pxe_default_server=
    root=hd1,gpt3
    ...

    No wonder that this grub2 can't find its way to the configfile because it needs an extra '@' symbol.

    Is this grub 2.02~beta2 's bug or the SLES 12 installer's bug?
    Thanks.

  2. #2

    Re: SLES 12 installation with secure boot - drop to grub2 shell

    On 17/03/2014 09:54, robertyschen wrote:

    > I just tried SLES 12 beta2 installation on our x86_64 machine. I enroll
    > the shim-sles.der certificate so that I can proceed the full
    > installation with secure boot enabled.
    >
    > After the installation, the system reboots normally. But it drops into
    > grub2 shell: grub>
    >
    > After some investigation, I found that this "grub2" can't find its
    > configfile. Because once I specify it manually as
    > grub> configfile (hd1,gpt3)/@/boot/grub2/grub.cfg
    >
    > The grub menu pops normally and I can boot into SLES without problems
    > (with secure boot enabled!!).
    >
    > The strange point is the grub2's root path includes an extra '@' symbol
    > after the root path. Check this:
    > grub>ls (hd1,gpt3)/
    > @/
    >
    > grub>ls (hd1,gpt3)/@
    > dev/ run/ selinux/ boot/ lib/ ......
    >
    > grub>set
    > ....
    > prefix=(hd1,gpt3)/boot/grub2
    > pxe_default_server=
    > root=hd1,gpt3
    > ...
    >
    > No wonder that this grub2 can't find its way to the configfile because
    > it needs an extra '@' symbol.
    >
    > Is this grub 2.02~beta2 's bug or the SLES 12 installer's bug?
    > Thanks.


    Since SLES12 is currently a closed beta, you should have received
    details of a mailing list to be used for reporting issues.

    HTH.
    --
    Simon
    SUSE Knowledge Partner

    ------------------------------------------------------------------------
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below. Thanks.
    ------------------------------------------------------------------------

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •