Hello,

I am new to this site - hoping someone can help with this issue.

SUSE Build:
# uname -a
Linux tsm1 3.0.13-0.27-default #1 SMP Wed Feb 15 13:33:49 UTC 2012 (d73692b) x86_64 x86_64 x86_64 GNU/Linux

I'm trying to build the lin_tape (IBM tape) driver. According to instructions, I'm running the command below and getting the errors shown:

# rpmbuild --rebuild lin_tape-2.5.0-1.src.rpm
Installing lin_tape-2.5.0-1.src.rpm
Executing(%prep): /bin/sh -e /var/tmp/rpm-tmp.93338
+ umask 022
+ cd /usr/src/packages/BUILD
+ cd /usr/src/packages/BUILD
+ rm -rf lin_tape-2.5.0
+ /usr/bin/gzip -dc /usr/src/packages/SOURCES/lin_tape-2.5.0.tgz
+ tar -xf -
+ STATUS=0
+ '[' 0 -ne 0 ']'
+ cd lin_tape-2.5.0
++ /usr/bin/id -u
+ '[' 0 = 0 ']'
+ /bin/chown -Rhf root .
++ /usr/bin/id -u
+ '[' 0 = 0 ']'
+ /bin/chgrp -Rhf root .
+ /bin/chmod -Rf a+rX,u+w,g-w,o-w .
+ exit 0
Executing(%build): /bin/sh -e /var/tmp/rpm-tmp.93338
+ umask 022
+ cd /usr/src/packages/BUILD
+ /bin/rm -rf /var/tmp/lin_tape-2.5.0-1-root-root
++ dirname /var/tmp/lin_tape-2.5.0-1-root-root
+ /bin/mkdir -p /var/tmp
+ /bin/mkdir /var/tmp/lin_tape-2.5.0-1-root-root
+ cd lin_tape-2.5.0
++ echo x86_64-suse-linux
++ cut -f 1 -d -
+ p=x86_64
+ '[' x86_64 == i386 ']'
+ '[' x86_64 == i586 ']'
+ '[' x86_64 == i686 ']'
+ '[' x86_64 == ppc64 ']'
+ '[' x86_64 == powerpc ']'
+ '[' x86_64 == powerpc64 ']'
+ '[' x86_64 == s390 ']'
+ '[' x86_64 == s390x ']'
+ '[' x86_64 == ia64 ']'
+ '[' x86_64 == x86_64 ']'
+ proc=AMD
+ cp -af lin_tape_359X_AMD.ReadMe lin_tape_359X.ReadMe
+ cp -af lin_tape_Ultrium_AMD.ReadMe lin_tape_Ultrium.ReadMe
+ make KERNEL=3.0.13-0.27-default PROC=x86_64 driver
make: Nothing to be done for `driver'.
+ exit 0
Executing(%install): /bin/sh -e /var/tmp/rpm-tmp.93338
+ umask 022
+ cd /usr/src/packages/BUILD
+ cd lin_tape-2.5.0
+ rm -rf /var/tmp/lin_tape-2.5.0-1-root-root
+ install -D -m 644 bldtmp/lin_tape-3.0.13-0.27-default.ko /var/tmp/lin_tape-2.5.0-1-root-root/lib/modules/3.0.13-0.27-default/kernel/drivers/scsi/lin_tape.ko
install: cannot stat `bldtmp/lin_tape-3.0.13-0.27-default.ko': No such file or directory
error: Bad exit status from /var/tmp/rpm-tmp.93338 (%install)


RPM build errors:
Bad exit status from /var/tmp/rpm-tmp.93338 (%install)

I have the following kernel packages installed:
# rpm -qa|grep kernel
kernel-trace-devel-3.0.101-0.7.17.1
kernel-default-3.0.13-0.27.1
kernel-default-devel-3.0.101-0.7.17.1
kernel-firmware-20110923-0.7.64
linux-kernel-headers-2.6.32-1.4.13
kernel-source-3.0.101-0.7.17.1
kernel-syms-3.0.101-0.7.17.1
kernel-xen-devel-3.0.101-0.7.17.1
kernel-default-base-3.0.13-0.27.1

Any help, hints, or suggestions would be greatly appreciated.

Thanks in advance