Results 1 to 10 of 15

Thread: SuSe Enterprise Server 11 will not load to the desktop

Threaded View

  1. #1

    Exclamation SuSe Enterprise Server 11 will not load to the desktop

    So, I am pretty new to the Linux environment in general. I have a dual boot Win7 and openSUSE 13.1 on my laptop. At school, I do computational research and we use a Dell Server with SuSE Enterprise 11. I was trying to install LibreOffice and I had a lot of issues which I won't get into here. I went into YaST and tried to delete the files I installed and then I rebooted the machine. After hitting "shutdown":

    The computer screen went blank and just the mouse was displaying, so I hit the power button and sent a kill signal. The computer then shut down like normal (displayed the usual text on the shutdown procedure).
    Upon restart it loaded up normally as far as I can tell and it just went to command prompt. Also, a little script I wrote is no longer accepted? bash: export: '/../../../..(there's no reason to write the path)/gdv.profile': not a valid identifier. (This script allows new users to run the computational software installed on the server).

    Things I tried:

    command: startx - this would load up a screen where just the mouse is on the screen and the rest is blank
    I went into /etc/X11/xinit/xinitrc and added the line:
    exec gnome-session
    in the middle of the file. This made it even worse!

    Then, I backed up xorg.conf as xorg_backup.conf and deleted the original file and reset the machine. Didn't work. I restored the original file.

    Here is another thing. In my Xorg.0.log shows WW warnings for a bunch of "fonts" files. Maybe this has to do with those files I deleted after trying to uninstall my failed LibreOffice attempt. Maybe some of these font files are system required?

    The computer still works as I am running calculations on it. But my professor and I would really like to have the desktop environment back so we can run spreadsheets and have a web browser.

    By the way: trying to run firefox from the command gives a no display error.

    Note: everything still works and the computational software package works fine (we run it from the shell anyway) - but we need the GUI environment for other tasks. Thank you.
    Last edited by erickabarnes; 28-Mar-2014 at 19:26.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts