I get an error updating xorg-x11-server to the latest version
(7.4-27.40.56.1). If the required version of libpciaccess0 should be >=
7.4.0_0.11.0 then it should work with version 7.4-8.26.3.1 installed...
Anyone with the same problem? Could it be a problem with the name of
the package (See hyphen and underscore in the package name)? Or is 7.4.0
not the same as 7.4?


# rpm -qa |grep xorg-x11-server
xorg-x11-server-7.4-27.19.19


# rpm -qa |grep libpciaccess0
libpciaccess0-7.4-8.26.3.1


# rug bin -r -y SLES11-SP1-UPDATES-BUNDLE-RELEASED-20120113
The following bundles will be installed:
SLES11-SP1-UPDATES-BUNDLE-RELEASED-20120113 (version 2)

ERROR: RPM_NOTHING_PROVIDES_DEP: 'libpciaccess0 >= 7.4.0_0.11.0' needed
by xorg-x11-server-7.4-27.40.56.1.x86_64


# rug se xorg-x11-server
S | Catalog | Bundle
| Name | Version | Arch
--+---------------------------------+------------------------------------------------+-----------------------+----------------+-------
v | SLES11_SP1-UPDATES-PROD-CATALOG |
SLES11-SP1-UPDATES-BUNDLE-RELEASED-20120113 | xorg-x11-server |
7.4-27.40.56.1 | x86_64
i | SLES11-SP1-POOL | SLES11-SP1-Pool-bundle
| xorg-x11-server | 7.4-27.19.19 | x86_64


# rug se libpciaccess0
S | Catalog | Bundle
| Name | Version | Arch
--+---------------------------------+------------------------------------------------+---------------------+--------------+-------
i | SLES11_SP1-UPDATES-PROD-CATALOG |
SLES11-SP1-UPDATES-BUNDLE-RELEASED-20120113 | libpciaccess0 |
7.4-8.26.3.1 | x86_64
s | SLES11-SP1-POOL | SLES11-SP1-Pool-bundle
| libpciaccess0 | 7.4-8.24.2 | x86_64


--
eloycastro
------------------------------------------------------------------------
eloycastro's Profile: http://forums.novell.com/member.php?userid=87076
View this thread: http://forums.novell.com/showthread.php?t=450790