I haven't worked with package locking/protecting using either zypper or
Yast2 Online Update before so please excuse me if this is an easy
question.

I needed to install the PHP OCI8 extension. This required php5-devel
which is available on the SLES 11 SP1 SDK DVD. This is not the newest
version of php5-devel, but it's the newest version provided by Novell,
and I like to use Novell-provided packages whenever possible.
Installing php5-devel from the SDK DVD required the downgrade of 15
dependencies. See the Yast2 conflicts list below.

> php5-devel-5.2.6-50.24.1.x86_64 requires php5 = 5.2.6, but this
> requirement cannot be provided
> uninstallable providers:
> php5-5.2.6-50.24.1.x86_64[SUSE-Linux-Enterprise-Software-Development-Kit-11-SP1_11.1.1-1.57]
>
> php5-5.2.6-50.24.1.x86_64[nu_novell_com:SLES11-SP1-Pool]
> [ ] Following actions will be done:
> downgrade of php5-5.2.14-0.7.24.1.x86_64 to php5-5.2.6-50.24.1.x86_64
> downgrade of php5-mysql-5.2.14-0.7.24.1.x86_64 to
> php5-mysql-5.2.6-50.24.1.x86_64
> downgrade of php5-tokenizer-5.2.14-0.7.24.1.x86_64 to
> php5-tokenizer-5.2.6-50.24.1.x86_64
> downgrade of php5-iconv-5.2.14-0.7.24.1.x86_64 to
> php5-iconv-5.2.6-50.24.1.x86_64
> downgrade of php5-ctype-5.2.14-0.7.24.1.x86_64 to
> php5-ctype-5.2.6-50.24.1.x86_64
> downgrade of php5-suhosin-5.2.14-0.7.24.1.x86_64 to
> php5-suhosin-5.2.6-50.24.1.x86_64
> downgrade of php5-zip-5.2.14-0.7.24.1.x86_64 to
> php5-zip-5.2.6-50.24.1.x86_64
> downgrade of php5-dom-5.2.14-0.7.24.1.x86_64 to
> php5-dom-5.2.6-50.24.1.x86_64
> downgrade of php5-mbstring-5.2.14-0.7.24.1.x86_64 to
> php5-mbstring-5.2.6-50.24.1.x86_64
> downgrade of php5-xmlreader-5.2.14-0.7.24.1.x86_64 to
> php5-xmlreader-5.2.6-50.24.1.x86_64
> downgrade of php5-xmlwriter-5.2.14-0.7.24.1.x86_64 to
> php5-xmlwriter-5.2.6-50.24.1.x86_64
> downgrade of php5-pdo-5.2.14-0.7.24.1.x86_64 to
> php5-pdo-5.2.6-50.24.1.x86_64
> downgrade of php5-hash-5.2.14-0.7.24.1.x86_64 to
> php5-hash-5.2.6-50.24.1.x86_64
> downgrade of php5-json-5.2.14-0.7.24.1.x86_64 to
> php5-json-5.2.6-50.24.1.x86_64
> downgrade of apache2-mod_php5-5.2.14-0.7.24.1.x86_64 to
> apache2-mod_php5-5.2.6-50.24.1.x86_64


Now that the dependencies have been downgraded and the php5-devel
package has been installed, whenever I open Yast2 Online Update, I get
the following message.

> php5-sqlite-5.2.6-50.24.1.x86_64 requires php5-pdo = 5.2.6, but this
> requirement cannot be provided
>
> [ ] Following actions will be done:
> deinstallation of php5-sqlite-5.2.6-50.24.1.x86_64
> deinstallation of php5-devel-5.2.6-50.24.1.x86_64
> [ ] do not install patch:slessp1-apache2-mod_php5-4663.noarch
>
> [ ] break php5-sqlite by ignoring some of its dependencies


I have been choosing option 2 ("do not install
patch:slessp1-apache2-mod_php5-4663.noarch") but I am wondering if
there's an easy way to lock the proper files so that I can continue
upgrading using Yast2 Online Update or "zypper update" without worrying
that I'll upgrade the wrong packages and break PHP's OCI8 extension.
There's no way to lock "patch:slessp1-apache2-mod_php5-4663.noarch" that
I know about, so would I simply lock the 15 packages that had to be
downgraded? Should I also lock php5-sqlite since that seems to be the
package requesting the upgrade of php5-pdo?

Any help/explanations would be greatly appreciated.

Thanks.
Dan


--
dcaunt
------------------------------------------------------------------------
dcaunt's Profile: http://forums.novell.com/member.php?userid=73309
View this thread: http://forums.novell.com/showthread.php?t=450999