Results 1 to 5 of 5

Thread: DomU comes up with resierfs filesystem read only

  1. #1

    DomU comes up with resierfs filesystem read only

    Hi all,

    One of our servers comes up with its / read only.
    I think I can fix that by doing reiserfsck on it, but I seem unable to umount / and check it and since its read only I cant force it to check on reboot.
    So I need to know if there is a way to send extra information at boot or if I can force the domU to boot without mounting root.
    Or if somebody have any other suggestions.

    Best regards

    /Lennart

  2. #2
    Rickb NNTP User

    Re: DomU comes up with resierfs filesystem read only

    lelle wrote:

    >
    > Hi all,
    >
    > One of our servers comes up with its / read only.
    > I think I can fix that by doing reiserfsck on it, but I seem unable to
    > umount / and check it and since its read only I cant force it to check
    > on reboot.
    > So I need to know if there is a way to send extra information at boot or
    > if I can force the domU to boot without mounting root.
    > Or if somebody have any other suggestions.
    >
    > Best regards
    >
    > /Lennart
    >
    >


    Is this on xen and how is the domu disks seen by dom0? What I mean are your
    vm's on a san? What are you using for the domu disks? Are you using off ocfs
    or physical disks assigned to domu?

  3. #3

    Re: DomU comes up with resierfs filesystem read only

    Hi, sorry for the lack of information. It's om xen and the wm are raw disk in a san.
    the dom0 is seeing the disk by there scsi id.

    /Lennart

  4. #4
    Rickb NNTP User

    Re: DomU comes up with resierfs filesystem read only

    lelle wrote:

    >
    > Hi, sorry for the lack of information. It's om xen and the wm are raw
    > disk in a san.
    > the dom0 is seeing the disk by there scsi id.
    >
    > /Lennart
    >
    >


    Ok than you can repair the disk using the dom0 fsck. Make sure the vm is
    shutdown and than from the command line on dom0 run fsck -options /dev/sd?
    where dev/sdx is the disk for the vm. It may need to be /dev/sd?1 or 2 since
    it is a vm. I have recovered several times this way. Using raw disks is a
    lot easier than if it is file-backed disk. That one is a little more
    complicated. This should fix you up.

  5. #5

    Re: DomU comes up with resierfs filesystem read only

    thanks a lot, worked great

    /Lennart

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •