I have an instance running on the AWS cloud. I had attempted to use YaST, or more specifically YOU yast online updater. During the update it had many warning about dependencies, so I had skipped them all in order to make the updater run.

Now I have somehow lost the ability to use yast or zypper. Is there a way to fix this?

Most of the similar problems that I have found on Google searches require you to use a DVD to update/reinstall, but with this server being on the cloud I do not know how I would get a copy of the DVD to use.