Thanks Jens for the reply.

1. SLES11SP1 is no longer supported, so I guess there must be some specific dependency to run this on SP1?
=> Yes my customer is still using SP1 and they are not open towards upgrading. They want the corescanner rpm's running on SP2 to be installable on SP1. While trying to install the rpm we get that libusb 1.00 dependency error.

2. What exactly do you see as an error? "but it still says that dependency is not fulfilled" is rather vague, as such dependencies can reflect at various level...
=>
rpm -ivh corescanner.rpm
error: Failed dependencies:
libusb-1_0-0 >= 1.0.0 is needed by corescanner
libudev.so.0 is needed by corescanner
After this I installed the usb-1_0 using yast but I still continiue getting above error while trying to install the rpm

3. How do you install your application, is it an RPM or are those otherwise bundled files? Same goes for "[installation of] the required libusb 1.0" - via RPM or by some other means?
=>to install the rpm i used terminal but I tried installing the libusb1.0 using yast

Typically, libraries are installed with symlinks reflecting individual version number, major version number and no version number at all. Have you considered linking to the "lib" in a way reflecting your exact requirements?

cd /usr/lib
ls -l *usb*
lrwxrwxrwx 1 root root 19 2014-05-22 21:08 libusb-0.1.so.4 -> libusb-0.1.so.4.4.4
-rwxr-xr-x 1 root root 35420 2009-09-03 19:55 libusb-0.1.so.4.4.4
lrwxrwxrwx 1 root root 19 2014-05-26 16:49 libusb-1.0.so.0 -> libusb-1.0.so.0.0.0
-rwxr-xr-x 1 root root 46780 2009-02-21 08:18 libusb-1.0.so.0.0.0

rpm -ivh corescanner.rpm
error: Failed dependencies:
libusb-1_0-0 >= 1.0.0 is needed by corescanner
libudev.so.0 is needed by corescanner

There does seem to be some naming difference between the install error (libusb-1_0-0 ) and the libusb i tried installing ( libusb-1.0.so.0 -> libusb-1.0.so.0.0.0)

Can that be an issue?

Thanks in advance