Guys,

I finally for this sorted out. As all my environment is using VMware Workstation and Virtual Machines for all nodes, I forgot to enable VT extensions for my CPU in VMware configuration for the Compute Node. Enabling that, everything started working as it should!

Hope this helps others.

Happy Clouding!

Oscar