On 02/09/2014 15:14, Cgreiner wrote:

> we need at Minimum Perl 5.12 for SLES11SP3 x86


Can I ask why?

> SLES11SP3 have all new patches and updates and Perl 5.10 is installed


Perl 5.10 is the latest version of Perl available and supported by SUSE
for SLES11 SP3. Even the openSUSE Build Service doesn't have a later
version available.

> by downloading the packets from opensource
> perl-base-5.12.3-11.14.1.i586.rpm we become a installation error: Failed
> dependencies perl-base 5.10 is needed by
> the same error comes on perl-5.12.3-11.14.1.x86_64.rpm (perl = 5.10.0
> is needed by .....
>
> how it is possible to install a newer version of perl as 5.10


Wherever you got perl-base-5.12.3-11.14.1.i586.rpm you'll need to grab
perl-5.12.3-11.14.1.i586.rpm plus other perl-*-5.12.3-11.14.1.i586.rpm
files. Note that you won't be supported by SUSE should you have any issues.

What's your timescale for requiring Perl 5.12? I ask because it's
possible that SLES12 will include a newer version of Perl.

HTH.
--
Simon
SUSE Knowledge Partner

------------------------------------------------------------------------
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below. Thanks.
------------------------------------------------------------------------