Hello,

as per subject I'm working on a SLESS 11 for VMware machine which has been upgraded from SLES11 SP1 to SLES 11 SP3, as I ws not the one who performed the upgrade I'm not sure what or how it has been performed.

The server is running kernel version 3.0.101-0.8-default which I would need to upgrade to 3.0.101-0.31-default and on top of this I see there are couple of more updates to installed Software that need be updated, when I issue a zypper update command I get the following :

Code:
Loading repository data...
Reading installed packages...

The following package updates will NOT be installed:


The following product updates will NOT be installed:


The following NEW packages are going to be installed:
  libopenobex1 perl-Module-Build perl-Test-Simple python-m2crypto
  subscription-tools

The following NEW product is going to be installed:
  SUSE Linux Enterprise Server 11 SP3 for VMware

The following package is going to be REMOVED:
  openobex

The following product is going to be REMOVED:
  SUSE Linux Enterprise Server 11 SP1 for VMware

The following packages are going to be upgraded:
  MozillaFirefox MozillaFirefox-translations PackageKit SLES-for-VMware-release
  SLES-for-VMware-release-DVD a2ps apache2 apache2-devel apache2-prefork
  apache2-utils augeas-lenses autoyast2 autoyast2-installation bind-libs
  bind-utils binutils checkmedia crash crash-sial ctags curl
  docbook-xsl-stylesheets file fontconfig fontconfig-32bit gdb
  gfxboot-branding-SLES glib2 glib2-devel glib2-lang glibc glibc-32bit
  glibc-devel glibc-i18ndata glibc-info glibc-locale hal hplip-hpijs hwinfo
  java-1_6_0-ibm kdump kernel-default kernel-default-base kernel-default-devel
  kernel-source kpartx libMagickCore1 libapr1 libapr1-devel libaugeas0
  libblkid1 libcurl-devel libcurl4 libdrm libexpat-devel libfreebl3 libgcc_s1
  libgcc_s1-32bit libgio-2_0-0 libgio-2_0-0-32bit libgio-fam libglib-2_0-0
  libglib-2_0-0-32bit libgmodule-2_0-0 libgmodule-2_0-0-32bit libgnutls26
  libgobject-2_0-0 libgobject-2_0-0-32bit libgomp1 libgthread-2_0-0
  libgthread-2_0-0-32bit libldap-2_4-2 libldap-2_4-2-32bit libldb1
  libmysqlclient_r15 libpng12-0 libpng12-0-32bit libpoppler-glib4 libpoppler5
  libpython2_6-1_0 libpython2_6-1_0-32bit libqdialogsolver1 libqt4
  libqt4-qt3support libqt4-sql libqt4-sql-mysql libqt4-x11 libsmbclient0
  libsnmp15 libsoftokn3 libstdc++6 libstdc++6-32bit libtalloc2 libtalloc2-32bit
  libtdb1 libtdb1-32bit libtevent0 libtevent0-32bit libudev0 libuuid1
  libuuid1-32bit libwbclient0 libwbclient0-32bit libxml2 libxml2-32bit
  libxml2-python libzypp linux-kernel-headers logrotate makedumpfile man-pages
  mdadm microcode_ctl mkinitrd mozilla-nspr mozilla-nss multipath-tools mutt
  nscd obex-data-server openldap2-client openldap2-devel openssh
  openssh-askpass openssl-certs pam pam-doc perl poppler-tools puppet python
  python-base python-pywbem python-tk python-xml release-notes-SLES-for-VMware
  rpcbind ruby samba samba-client samba-client-32bit satsolver-tools sg3_utils
  sle-sdk-release sle-sdk-release-SDK sles-admin_en-pdf sles-deployment_en-pdf
  sles-installquick_en-pdf sles-manuals_en sles-security_en-pdf
  sles-storage_en-pdf smis-providers smt-client snmp-mibs star sudo
  supportutils suse-build-key tcsh timezone udev util-linux util-linux-lang
  uuid-runtime wget x11-input-wacom xinetd xorg-x11-libs xorg-x11-libs-32bit
  yast2 yast2-add-on yast2-firewall yast2-installation yast2-iscsi-client
  yast2-libyui yast2-ncurses yast2-ncurses-pkg yast2-network yast2-nfs-client
  yast2-online-update yast2-packager yast2-perl-bindings yast2-pkg-bindings
  yast2-python-bindings yast2-qt yast2-qt-pkg yast2-registration
  yast2-samba-client yast2-slp-server yast2-storage yast2-storage-lib
  yast2-update yast2-wagon yast2-ycp-ui-bindings zlib zlib-devel zsh zypper

The following product is going to be upgraded:
  SUSE Linux Enterprise Software Development Kit 11 SP3

The following package needs additional customer contract to get support:
  libmysqlclient_r15

The following packages are not supported by their vendor:
  apache2 apache2-devel apache2-prefork apache2-utils crash
  docbook-xsl-stylesheets gfxboot-branding-SLES glib2-devel glibc-info
  java-1_6_0-ibm libapr1 libapr1-devel libcurl-devel libexpat-devel libgio-fam
  libopenobex1 libqdialogsolver1 libudev0 makedumpfile obex-data-server
  openldap2-devel poppler-tools python-m2crypto python-tk
  release-notes-SLES-for-VMware sle-sdk-release sle-sdk-release-SDK
  x11-input-wacom yast2-python-bindings yast2-slp-server zlib-devel

198 packages to upgrade, 5 new, 1 to remove.
Overall download size: 428.6 MiB. After the operation, additional 58.8 MiB will
be used
What I cannot understand is why SUSE Linux Enterprise Server 11 SP1 for VMware is in there, in all the other SP3 machines that I've personally upgraded this never came up so I'm a bit puzzled, what also I cannot understand is the last message The following packages are not supported by their vendor: what does that mean? I'm more of a RH guy and in many years never seen such a message so I'm double puzzled :-)

If I proceed with the update it seems to run smoothly but at the end of it if I try to run zypper update (or lr) or many other commands I cnanot recall at the moment I get the following:

Code:
 zypper update
zypper: /lib64/libz.so.1: no version information available (required by /usr/lib64/libxml2.so.2)
zypper: /lib64/libz.so.1: no version information available (required by /usr/lib64/libxml2.so.2)
zypper: /lib64/liblzma.so.5: no version information available (required by /usr/lib64/libxml2.so.2)
zypper: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by /usr/lib64/libxml2.so.2)
zypper: /lib64/libc.so.6: version `GLIBC_2.15' not found (required by /usr/lib64/libxml2.so.2)
Message per se is pretty clear but I confirmed all required libraries/files are indeed where they should be, I've also tried to manually update these files to the latest available release but problem is exactly the same.

Honestly I ran out of ideas and find myself stuck with this system that needs updates but cannot deploy them, does anyone have an idea what the issue could be or what I could do?

Thanks in advance for any help which would highly appreciated