Hi tkindig,
Quote Originally Posted by tkindig View Post
I have a pair of new clustered servers running SLES 11 SP3 with the high availability extensions. These two hosts are running the XEN kernel. I followed the instructions for Enabling VNC Server on startup of the X server with SLE 11 (https://www.novell.com/support/kb/doc.php?id=7003097) to the letter. The server refuses my VNC connection with port:0, 5900, and no port. When I look for a running instance of VNC I find only the following:

root 3160 4.1 0.0 111528 9896 ? SLl Sep04 237:57 /usr/lib/xen/bin/qemu-dm -d 3 -domain-name winserver2012 -videoram 4 -k en-us -vnc 127.0.0.1:0 -vncunused -vcpus 2 -vcpu_avail 0x3 -boot c -localtime -serial pty -acpi -usb -usbdevice tablet -watchdog-action reset -net nic,vlan=1,macaddr=00:16:3e:36:28:93,model=rtl8139 ,bridge=br0 -net tap,vlan=1,ifname=vif3.0-emu,bridge=br0,script=no,downscript=no -M xenfv

Which seems to be only for console access to a running guest. I do not know what else to look at. Once I login as root the VNC connection is accepted. I would appreciate any pointers.
the problem most probably is caused by an "inconsistent" configuration:

- the KB article describes to use port 5900 for the X server's VNC port (Option "rfbport" "5900"), which it will like try to open on "all interfaces"
- your DomU is configured to provide VNC access and is either configured explicitly to use 5900 or chose so because it (then) was the first free port. It will only listen on "lo", though
- most likely, the X server got started after the VM, hence it no longer could listen on *:5900 (since 127.0.0.1:5900 already is opened by qemu-dm)

Personally, I recommend setting explicit ports for VNC access to DomUs anyhow, so you very well may set those to something starting at 5910 or similar, to avoid clashes.

Regards,
Jens