While doing the rounds and patching a bunch of SLES server for ShellShock, I then proceeded to patch my trusty SLED 11 SP3 workstation. While at it, I noticed the security patch listed in YOU for kernel 3.0.76-0.11 and installed it as well. It completed OK, but after a reboot I have some weirdness like I have never seen before.

Basically the system only mounts /boot, /home and SWAP.

After rebooting into failsafe mode with runlevel 1, and "confirm" I was able to find the first sign on the problem.

Activating swap-devices in /etc/fstab...
rm: cannot remove /etc/mtab : No space left on device
can't create lock file /etc/mtab~833: No space left on device (use -n flag to override)
Then after bootup script boot.localfs starts, it displays similar errors for mounting all the fstab entries, with the same error:
can't create lock file /etc/mtab~833: No space left on device (use -n flag to override)
except that the number above "833" increments. See screen shot - file sys mount errors.
(The screen shot was difficult to catch as it scrolled by, so I filmed it with my ipad, then extracted a frame).

Once the system completes boot, I can actually log in as root.
lsblk lists all my partitions correctly, but with only /boot, /home and swap mounted.
Even though / isn't mounted I can navigate it and /home with with cd, ls etc. !? I didn't think this would be possible!

mount - shows nothing is mounted, so contradicts lsblk!

mount -a
mount: /dev/sdc1 already mounted or /boot busy
mount: /dev/md0 already mounted or /home busy
mount: devpts already mounted or /dev/pts busy
If it matters, / is btrfs and is mounted using UUID in fstab. I'm just about to reboot with a rescue disk and set this to good old fashion /dev/sdc2 (instead of UUID) to see if it helps...

I've tried to fix this for a few hours already, so I hope someone may have seen this before, and can offer some insight into what the kernel (and/or shellshock) update might have done.

Cheers, Gordon