Results 1 to 5 of 5

Thread: gimp-2.8 in SLE 11 sp3

Hybrid View

  1. #1

    gimp-2.8 in SLE 11 sp3

    Hello:

    I am trying to compile gimp-2.8 in SLED 11 sp3, but it seems that the system GTK version is too low which cost countless problems. I am just wondering could anybody provide the repository for gimp-2.8 under SLED 11 sp3?

    I found one from software.opensuse.org, but it is only for SLED 11 SP2. It have some problems to install it in 11 SP3.

    thank you very much.

    Albert

  2. #2

    Re: gimp-2.8 in SLE 11 sp3

    Quote Originally Posted by albumns View Post
    Hello:

    I am trying to compile gimp-2.8 in SLED 11 sp3, but it seems that the system GTK version is too low which cost countless problems. I am just wondering could anybody provide the repository for gimp-2.8 under SLED 11 sp3?

    I found one from software.opensuse.org, but it is only for SLED 11 SP2. It have some problems to install it in 11 SP3.
    I can't find a SLED 11 SP2 version at software.opensuse.org and I doubt there is 'a repository for gimp-2.8 under SLED 11 sp3'. Like you said it needs a newer GTK version and that is very problematic. You can't simply update the version of GTK you have installed because it's used by GNOME. Years ago there was the same problem with Firefox 3 and SLED 10. Firefox 3 needed a newer version of GTK than was in SLED 10 and Mozilla dropped support for Firefox 2. Novell solved the problem by back porting security fixes in to Firefox 3 themselves for a while and then providing a Firefox 3 package that had dependencies on additional packages called things like firefox3-gtk2 that provided the required version of GTK and other dependencies separately to the version of GTK that everything else in SLED 10 needed. The same would need to be done with GIMP 2.8.

    I looked in to building GIMP 2.8 for SLED 11 SP3 earlier this year. For what it's worth, the script I came up with is below. It's from May and I haven't looked at it since or actually used GIMP 2.8 much since everything I've wanted to do with GIMP has been achievable with 2.6. I offer no guarantees about the functionality of the result. I ran the script just now to make sure it still works. Some of the library versions are probably out of date by now.


    The recently released SLED 12 has GIMP 2.8

    Code:
    #!/bin/bash
    # Requires the following packages from SLED 11 SP3 and SLE SDK 11 SP3:
    # automake gcc libtool fam-devel libffi-devel intltool sdl-devel asciidoc lua-devel libjpeg-devel libpng-devel librsvg-devel  libjasper-devel libopenraw-devel libkexiv2-3-devel enscript OpenEXR-devel  gtk-doc gobject-introspection libcurl-devel python-gtk-devel libexif-devel
    #
    #
    # GIMPINSTDIR is where GIMP will be installed.
    export GIMPINSTDIR=~/apps/gimp2.8
    #
    #
    export PKG_CONFIG_PATH=${GIMPINSTDIR}/lib/pkgconfig
    export LD_LIBRARY_PATH=${GIMPINSTDIR}/lib
    export LIBFFI_LIBS="-L/usr/lib64/ -lffi"
    export LIBFFI_CFLAGS="-I/usr/include"
    export JOBS=$(grep -c ^processor /proc/cpuinfo)
    mkdir gimp28stuff
    cd gimp28stuff
    curl http://download.gimp.org/pub/gegl/0.2/gegl-0.2.0.tar.bz2 | tar xvfj -
    curl http://download.gimp.org/pub/babl/0.1/babl-0.1.10.tar.bz2 | tar xvfj -
    curl ftp://ftp.gnome.org/pub/gnome/sources/gtk+/2.24/gtk+-2.24.18.tar.xz | tar xvfJ -
    curl ftp://ftp.gnome.org/pub/gnome/sources/glib/2.31/glib-2.31.18.tar.xz | tar xvfJ -
    curl ftp://ftp.gnome.org/pub/gnome/sources/gdk-pixbuf/2.24/gdk-pixbuf-2.24.1.tar.xz | tar xvfJ -
    curl http://cairographics.org/releases/pixman-0.24.4.tar.gz | tar xvfz -
    curl ftp://ftp.gnome.org//pub/gnome/sources/atk/2.3/atk-2.3.95.tar.xz | tar xvfJ -
    curl http://download.gimp.org/pub/gimp/v2.8/gimp-2.8.4.tar.bz2  | tar xvfj -
    curl http://cairographics.org/releases/cairo-1.12.14.tar.xz  | tar xvfJ -
    curl http://poppler.freedesktop.org/poppler-0.22.4.tar.gz | tar xvfz -
    curl ftp://ftp.gnome.org/pub/gnome/sources/pango/1.29/pango-1.29.5.tar.xz | tar xvfJ -
    curl -L http://download.sourceforge.net/libpng/libpng-1.2.50.tar.xz | tar  xvfJ -
    cd babl-0.1.10
    ./configure --prefix=${GIMPINSTDIR} && make -j ${JOBS} && make install
    cd ../glib-2.31.18/
    ./configure --prefix=${GIMPINSTDIR} && make -j ${JOBS} && make install
    cd ../gegl-0.2.0/
    ./configure --prefix=${GIMPINSTDIR} && make -j ${JOBS} && make install
    cd ../atk-2.3.95/
    ./configure --prefix=${GIMPINSTDIR} && make -j ${JOBS} && make install
    cd ../pango-1.29.5/
    ./configure --prefix=${GIMPINSTDIR} && make -j ${JOBS} && make install
    cd ../gdk-pixbuf-2.24.1/
    ./configure --prefix=${GIMPINSTDIR} && make -j ${JOBS} && make install
    cd ../pixman-0.24.4/
    ./configure --prefix=${GIMPINSTDIR} && make -j ${JOBS} && make install
    cd ../cairo-1.12.14/
    ./configure --prefix=${GIMPINSTDIR} && make -j ${JOBS} && make install
    cd ../poppler-0.22.4/
    ./configure --prefix=${GIMPINSTDIR} && make -j ${JOBS} && make install
    cd ../cairo-1.12.14/
    ./configure --prefix=${GIMPINSTDIR} && make -j ${JOBS} && make install
    cd ../libpng-1.2.50/
    ./configure --prefix=${GIMPINSTDIR} && make -j ${JOBS} && make install
    cd ../gtk+-2.24.18/
    ./configure --prefix=${GIMPINSTDIR} && make -j ${JOBS} ; sed -i 's!/usr/lib64:!!' gtk/gtk-query-immodules-2.0 && rm -f modules/input/.libs/*.so && cd modules/input/ && make clean && cd - && make -j ${JOBS} && make install
    cd ../gimp-2.8.4/
    ./configure --prefix=${GIMPINSTDIR} && make -j ${JOBS} && make install
    If you find this post helpful and are logged into the web interface, please show your appreciation and click on the star below... thanks!

  3. #3

    Re: gimp-2.8 in SLE 11 sp3

    it failed with messages:

    configure: error: Package requirements (gegl-0.2 >= 0.2.0) were not met:

    No package 'gegl-0.2' found

    Consider adjusting the PKG_CONFIG_PATH environment variable if you
    installed software in a non-standard prefix.



  4. #4

    Re: gimp-2.8 in SLE 11 sp3

    Quote Originally Posted by albumns View Post
    it failed with messages:

    configure: error: Package requirements (gegl-0.2 >= 0.2.0) were not met:

    No package 'gegl-0.2' found

    Consider adjusting the PKG_CONFIG_PATH environment variable if you
    installed software in a non-standard prefix.


    Hmmm. Well it still works for me. I can't just figure out why you'd get that error. Your other posts suggests you've updated to SLED 12 now though, is that the case?
    If you find this post helpful and are logged into the web interface, please show your appreciation and click on the star below... thanks!

  5. #5

    Re: gimp-2.8 in SLE 11 sp3

    Hello Mikewillis:

    Many thanks for such kind explanations.

    It seems that the case is more complicated that I expected. I am running some professional software under SLED 11 SP3 and some software doesn't work well under new GTK. So I have to stick to them....

    I will try your script these days and I am also looking forward to the one in the depository...

    Thanks again for kind helps.

    Albert

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •