I have used SLES 11 SP2 High Availbility Extension and configured DRBD, XEN VM''s etc without issue.

I am now trialing SLES 12 with its High Availability Extensions. Getting used to Hawk is interesting enough (loved pacemaker GUI).

My issue is that I tried to create a DRBD resource (the same as I did on SLES 11 SP2) and it will not start. I also created a Pingd resource and it too will not start.

This was a given in SLES 11 SP2, yet in SLES 12 I cannot understand why its failing.

An error message Hawk shows is

linux3: WARN: passwordless ssh to node(s) linux4 does not work
Permission denied (publickey,keyboard-interactive).
tar: This does not look like a tar archive
tar: Exiting with failure status due to previous errors

Where linux3 and linux4 represent my 2 SLES 12 servers.

I do not recall configuring SSH for HA in SLES 11 SP2 before - it just worked.

I cannot seem to find any documentation on this error or how to set it up for HA use.

Can anybody shed some light on this issue?