Results 1 to 6 of 6

Thread: Issue with LVM on SLES 12

Threaded View

  1. #1

    Question Issue with LVM on SLES 12

    I am having an issue with LVM on SLES 12. My environment is SLES 12 running on System z but I think that this could be affecting all SLES 12 environments.

    My issue is that I am not able to have a Logical Volume automatically mounted after a reboot. This is a test system so I used the CLI to create the physical volume, the volume group, and the Logical Volume and then created an ext3 filesystem on it. I can mount the LV but after a reboot the LV is marked as 'NOT available' (from the lvdisplay command). If I issue 'vgchange -ay' the LV status changes to 'available' but upon reboot it is 'NOT available'. This is a major problem if I update /etc/fstab to mount this LV as the system boots into recovery mode because the LV is not available.

    I've tried using the systemctl commands to start and enable lvm2-monitor.service and lvm2-activation but nothing seems to enable LVM at boot time (SLES 11 required boot.lvm to be enabled but this doesn't exist in SLES 12). I tried using YaST | System | Services Manager also and get an error when I click OK to write out the configuration change.

    Chapter 4.6 in the SLES 12 Storage Administration Guide apparently was never updated for SLES 12 as it refers to using/modifying files /etc/sysconfig/lvm and etc/rc.d/boot.lvm - neither of these files exist in SLES 12. I searched for files 'lvm' and 'boot.lvm' with the find command and displayed the files installed with package lvm2-2.02.98-48.8.s390x - they don't exist.

    Google searches haven't uncovered anything helpful. I believe that I checked the zipl parameters and the grub2 parameters for this but I could be mistaken.

    Any ideas as to what I need to do to get LVM to start at boot time?


    Harley
    Last edited by x0500hl; 16-Dec-2014 at 18:57.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •