Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: X Display Failure

  1. #1

    X Display Failure

    Good afternoon,

    I don't know what happened, but this morning my Linux box doesn't switch to runlevel 5 anymore. On console screen, the error below happen:

    "warning gdmdisplay display lasted 0.0015 seconds
    WARNING: GdmLocalDisplayFactory: maximum number of X display failures reached: check X server log for errors"

    I can work only in text mode.

    Any ideas on how to fix this ?

    Thanks in advance

    Maurizio

  2. #2

    Re: X Display Failure

    Quote Originally Posted by mauriB View Post
    WARNING: GdmLocalDisplayFactory: maximum number of X display failures reached: check X server log for errors"
    Any clues in /var/log/Xorg.0.log ?
    If you find this post helpful and are logged into the web interface, please show your appreciation and click on the star below... thanks!

  3. #3

    Re: X Display Failure

    On 17/12/2014 12:34, mauriB wrote:

    > my Linux box


    Perhaps you could let us know which version of SLED you're using -
    please post the output from "cat /etc/*release".

    HTH.
    --
    Simon
    SUSE Knowledge Partner

    ------------------------------------------------------------------------
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below. Thanks.
    ------------------------------------------------------------------------

  4. #4

    Re: X Display Failure

    Hi Mike,

    I forgot to say that my Linux is a SLED 11 X64 3.0.101-0.40-default #1 SMP. Below the log file...



    Code:
    X.Org X Server 1.6.5
    Release Date: 2009-10-11
    X Protocol Version 11, Revision 0
    Build Operating System: openSUSE SUSE LINUX
    Current Operating System: Linux A54CC749 3.0.101-0.40-default #1 SMP Thu Sep 18 13:09:38 UTC 2014 (44b8c95) x86_64
    Build Date: 27 June 2014  11:55:00AM
     
    	Before reporting problems, check http://wiki.x.org
    	to make sure that you have the latest version.
    Markers: (--) probed, (**) from config file, (==) default setting,
    	(++) from command line, (!!) notice, (II) informational,
    	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    (==) Log file: "/var/log/Xorg.0.log", Time: Thu Dec 18 08:19:30 2014
    (==) Using config file: "/etc/X11/xorg.conf"
    (==) ServerLayout "Layout[all]"
    (**) |-->Screen "Screen[0]" (0)
    (**) |   |-->Monitor "Monitor[0]"
    (**) |   |-->Device "Device[0]"
    (**) |-->Input Device "Keyboard[0]"
    (**) |-->Input Device "Mouse[1]"
    (**) |-->Input Device "Mouse[3]"
    (**) Option "ZapWarning" "on"
    (**) Option "AllowMouseOpenFail" "on"
    (**) Option "Xinerama" "off"
    (**) Option "AIGLX" "on"
    (==) Not automatically adding devices
    (==) Automatically enabling devices
    (WW) The directory "/usr/share/fonts/local" does not exist.
    	Entry deleted from font path.
    (WW) The directory "/usr/share/fonts/PEX" does not exist.
    	Entry deleted from font path.
    (WW) The directory "/usr/share/fonts/latin2/misc" does not exist.
    	Entry deleted from font path.
    (WW) The directory "/usr/share/fonts/latin2/75dpi" does not exist.
    	Entry deleted from font path.
    (WW) The directory "/usr/share/fonts/latin2/100dpi" does not exist.
    	Entry deleted from font path.
    (WW) The directory "/usr/share/fonts/latin2/Type1" does not exist.
    	Entry deleted from font path.
    (WW) The directory "/usr/share/fonts/latin7/75dpi" does not exist.
    	Entry deleted from font path.
    (WW) The directory "/usr/share/fonts/baekmuk" does not exist.
    	Entry deleted from font path.
    (WW) The directory "/usr/share/fonts/japanese" does not exist.
    	Entry deleted from font path.
    (WW) The directory "/usr/share/fonts/kwintv" does not exist.
    	Entry deleted from font path.
    (WW) The directory "/usr/share/fonts/uni" does not exist.
    	Entry deleted from font path.
    (WW) The directory "/usr/share/fonts/CID" does not exist.
    	Entry deleted from font path.
    (WW) The directory "/usr/share/fonts/ucs/misc" does not exist.
    	Entry deleted from font path.
    (WW) The directory "/usr/share/fonts/ucs/75dpi" does not exist.
    	Entry deleted from font path.
    (WW) The directory "/usr/share/fonts/ucs/100dpi" does not exist.
    	Entry deleted from font path.
    (WW) The directory "/usr/share/fonts/hellas/misc" does not exist.
    	Entry deleted from font path.
    (WW) The directory "/usr/share/fonts/hellas/75dpi" does not exist.
    	Entry deleted from font path.
    (WW) The directory "/usr/share/fonts/hellas/100dpi" does not exist.
    	Entry deleted from font path.
    (WW) The directory "/usr/share/fonts/hellas/Type1" does not exist.
    	Entry deleted from font path.
    (WW) The directory "/usr/share/fonts/misc/sgi" does not exist.
    	Entry deleted from font path.
    (WW) The directory "/usr/share/fonts/xtest" does not exist.
    	Entry deleted from font path.
    (WW) The directory "/opt/kde3/share/fonts" does not exist.
    	Entry deleted from font path.
    (WW) The directory "/usr/share/fonts/TTF/" does not exist.
    	Entry deleted from font path.
    (WW) The directory "/usr/share/fonts/OTF" does not exist.
    	Entry deleted from font path.
    (**) FontPath set to:
    	/usr/share/fonts/misc:unscaled,
    	/usr/share/fonts/75dpi:unscaled,
    	/usr/share/fonts/100dpi:unscaled,
    	/usr/share/fonts/Type1,
    	/usr/share/fonts/URW,
    	/usr/share/fonts/Speedo,
    	/usr/share/fonts/cyrillic,
    	/usr/share/fonts/truetype,
    	/usr/share/fonts/misc:unscaled,
    	/usr/share/fonts/truetype/,
    	/usr/share/fonts/Type1/,
    	/usr/share/fonts/100dpi:unscaled,
    	/usr/share/fonts/75dpi:unscaled
    (**) Input device list set to "/dev/gpmdata,/dev/input/mice"
    (==) ModulePath set to "/usr/lib64/xorg/modules/updates,/usr/lib64/xorg/modules"
    (**) Extension "Composite" is enabled
    (II) Loader magic: 0xcc0
    (II) Module ABI versions:
    	X.Org ANSI C Emulation: 0.4
    	X.Org Video Driver: 5.0

  5. #5

    Re: X Display Failure

    Good afternoon,

    thank for the replay, my SUSe is a

    "SUSE Linux Enterprise Desktop 11 (x86_64)
    VERSION = 11
    PATCHLEVEL = 3"

    kernel 3.0.101-0.40-default #1 SMP

    Maurizio

  6. #6

    Re: X Display Failure

    Quote Originally Posted by mauriB View Post
    Hi Mike,

    I forgot to say that my Linux is a SLED 11 X64 3.0.101-0.40-default #1 SMP. Below the log file...
    Is that the whole log file? It looks truncated and there's no errors in there.
    If you find this post helpful and are logged into the web interface, please show your appreciation and click on the star below... thanks!

  7. #7

    Re: X Display Failure

    ...no, it's my fault. Here the missing section
    But there are also Xorg.1.log Xorg.2.log,Xorg.3.log,Xorg.4.log,Xorg.5.log Is it correct?

    And if I do a # ps -ef|grep X

    root 3197 1 0 08:19 tty7 00:00:01 /usr/bin/X :0 -br -verbose -auth /var/run/gdm/auth-for-gdm-F79gNQ/database -nolisten tcp vt7
    root 4303 1 0 08:19 tty8 00:02:49 /usr/bin/X :1 -br -verbose -auth /var/run/gdm/auth-for-gdm-PCZd6u/database -nolisten tcp vt8
    root 5125 1 0 08:19 tty9 00:00:01 /usr/bin/X :2 -br -verbose -auth /var/run/gdm/auth-for-gdm-iDc1NT/database -nolisten tcp vt9
    root 5817 1 0 08:20 tty11 00:02:50 /usr/bin/X :3 -br -verbose -auth /var/run/gdm/auth-for-gdm-S2fH54/database -nolisten tcp vt11
    root 6590 1 0 08:20 tty12 00:02:50 /usr/bin/X :4 -br -verbose -auth /var/run/gdm/auth-for-gdm-vnLOj3/database -nolisten tcp vt12
    root 7363 1 0 08:20 tty13 00:03:35 /usr/bin/X :5 -br -verbose -auth /var/run/gdm/auth-for-gdm-T5vYMU/database -nolisten tcp vt13
    root 9609 9117 0 17:40 pts/0 00:00:00 grep X

    I find a lot of server X running...



    Code:
    (II) Module ABI versions:
    	X.Org ANSI C Emulation: 0.4
    	X.Org Video Driver: 5.0
    	X.Org XInput driver : 4.0
    	X.Org Server Extension : 2.0
    (II) Loader running on linux
    (++) using VT number 7
    
    (--) PCI:*(0:0:2:0) 8086:0126:103c:161c Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller rev 9, Mem @ 0xd4000000/4194304, 0xc0000000/268435456, I/O @ 0x00004000/64
    (II) Open ACPI successful (/var/run/acpid.socket)
    (II) System resource ranges:
    	[0] -1	0	0xffffffff - 0xffffffff (0x1) MX[B]
    	[1] -1	0	0x000f0000 - 0x000fffff (0x10000) MX[B]
    	[2] -1	0	0x000c0000 - 0x000effff (0x30000) MX[B]
    	[3] -1	0	0x00000000 - 0x0009ffff (0xa0000) MX[B]
    	[4] -1	0	0x0000ffff - 0x0000ffff (0x1) IX[B]
    	[5] -1	0	0x00000000 - 0x00000000 (0x1) IX[B]
    (WW) "dri" will not be loaded unless you've specified it to be loaded elsewhere.
    (II) "extmod" will be loaded. This was enabled by default and also specified in the config file.
    (II) "dbe" will be loaded. This was enabled by default and also specified in the config file.
    (II) "glx" will be loaded. This was enabled by default and also specified in the config file.
    (II) "record" will be loaded by default.
    (II) "dri" will be loaded even though the default is to disable it.
    (II) "dri2" will be loaded by default.
    (II) LoadModule: "dbe"
    (II) Loading /usr/lib64/xorg/modules//extensions/libdbe.so
    (II) Module dbe: vendor="X.Org Foundation"
    	compiled for 1.6.5, module version = 1.0.0
    	Module class: X.Org Server Extension
    	ABI class: X.Org Server Extension, version 2.0
    (II) Loading extension DOUBLE-BUFFER
    (II) LoadModule: "freetype"
    (WW) Warning, couldn't open module freetype
    (II) UnloadModule: "freetype"
    (EE) Failed to load module "freetype" (module does not exist, 0)
    (II) LoadModule: "extmod"
    (II) Loading /usr/lib64/xorg/modules//extensions/libextmod.so
    (II) Module extmod: vendor="X.Org Foundation"
    	compiled for 1.6.5, module version = 1.0.0
    	Module class: X.Org Server Extension
    	ABI class: X.Org Server Extension, version 2.0
    (II) Loading extension MIT-SCREEN-SAVER
    (II) Loading extension XFree86-VidModeExtension
    (II) Loading extension XFree86-DGA
    (II) Loading extension DPMS
    (II) Loading extension XVideo
    (II) Loading extension XVideo-MotionCompensation
    (II) Loading extension X-Resource
    (II) LoadModule: "glx"
    (II) Loading /usr/lib64/xorg/modules//extensions/libglx.so
    (II) Module glx: vendor="X.Org Foundation"
    	compiled for 1.6.5, module version = 1.0.0
    	ABI class: X.Org Server Extension, version 2.0
    (**) AIGLX enabled
    (II) Loading extension GLX
    (II) LoadModule: "record"
    (II) Loading /usr/lib64/xorg/modules//extensions/librecord.so
    (II) Module record: vendor="X.Org Foundation"
    	compiled for 1.6.5, module version = 1.13.0
    	Module class: X.Org Server Extension
    	ABI class: X.Org Server Extension, version 2.0
    (II) Loading extension RECORD
    (II) LoadModule: "dri2"
    (II) Loading /usr/lib64/xorg/modules//extensions/libdri2.so
    (II) Module dri2: vendor="X.Org Foundation"
    	compiled for 1.6.5, module version = 1.1.0
    	ABI class: X.Org Server Extension, version 2.0
    (II) Loading extension DRI2
    (II) LoadModule: "intel"
    (II) Loading /usr/lib64/xorg/modules//drivers/intel_drv.so
    (II) Module intel: vendor="X.Org Foundation"
    	compiled for 1.6.5, module version = 2.21.4
    	Module class: X.Org Video Driver
    	ABI class: X.Org Video Driver, version 5.0
    (II) LoadModule: "kbd"
    (II) Loading /usr/lib64/xorg/modules//input/kbd_drv.so
    (II) Module kbd: vendor="X.Org Foundation"
    	compiled for 1.6.5, module version = 1.3.2
    	Module class: X.Org XInput Driver
    	ABI class: X.Org XInput driver, version 4.0
    (II) LoadModule: "mouse"
    (II) Loading /usr/lib64/xorg/modules//input/mouse_drv.so
    (II) Module mouse: vendor="X.Org Foundation"
    	compiled for 1.6.5, module version = 1.4.0
    	Module class: X.Org XInput Driver
    	ABI class: X.Org XInput driver, version 4.0
    (II) LoadModule: "synaptics"
    (II) Loading /usr/lib64/xorg/modules//input/synaptics_drv.so
    (II) Module synaptics: vendor="X.Org Foundation"
    	compiled for 1.6.5, module version = 1.1.3
    	Module class: X.Org XInput Driver
    	ABI class: X.Org XInput driver, version 4.0
    (II) intel: Driver for Intel Integrated Graphics Chipsets: i810,
    	i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G, 915G,
    	E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM, Pineview G,
    	965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33, GM45,
    	4 Series, G45/G43, Q45/Q43, G41, B43, B43, Clarkdale, Arrandale,
    	Sandybridge Desktop (GT1), Sandybridge Desktop (GT2),
    	Sandybridge Desktop (GT2+), Sandybridge Mobile (GT1),
    	Sandybridge Mobile (GT2), Sandybridge Mobile (GT2+),
    	Sandybridge Server, Ivybridge Mobile (GT1), Ivybridge Mobile (GT2),
    	Ivybridge Desktop (GT1), Ivybridge Desktop (GT2), Ivybridge Server,
    	Ivybridge Server (GT2), Haswell Desktop (GT1), Haswell Desktop (GT2),
    	Haswell Desktop (GT2+), Haswell Mobile (GT1), Haswell Mobile (GT2),
    	Haswell Mobile (GT2+), Haswell Server (GT1), Haswell Server (GT2),
    	Haswell Server (GT2+), Haswell SDV Desktop (GT1),
    	Haswell SDV Desktop (GT2), Haswell SDV Desktop (GT2+),
    	Haswell SDV Mobile (GT1), Haswell SDV Mobile (GT2),
    	Haswell SDV Mobile (GT2+), Haswell SDV Server (GT1),
    	Haswell SDV Server (GT2), Haswell SDV Server (GT2+), HD Graphics,
    	Haswell ULT Desktop (GT1), Haswell ULT Desktop (GT2),
    	Haswell ULT Desktop (GT2+), Haswell ULT Mobile (GT1),
    	Haswell ULT Mobile (GT2), Haswell ULT Mobile (GT2+),
    	Haswell ULT Server (GT1), Haswell ULT Server (GT2),
    	Haswell ULT Server (GT2+), Haswell CRW Desktop (GT1),
    	Haswell CRW Desktop (GT2), Haswell CRW Desktop (GT2+),
    	Haswell CRW Mobile (GT1), Haswell CRW Mobile (GT2),
    	Haswell CRW Mobile (GT2+), Haswell CRW Server (GT1),
    	Haswell CRW Server (GT2), Haswell CRW Server (GT2+),
    	ValleyView PO board
    (II) Primary Device is: PCI 00@00:02:0
    (II) resource ranges after probing:
    	[0] -1	0	0xffffffff - 0xffffffff (0x1) MX[B]
    	[1] -1	0	0x000f0000 - 0x000fffff (0x10000) MX[B]
    	[2] -1	0	0x000c0000 - 0x000effff (0x30000) MX[B]
    	[3] -1	0	0x00000000 - 0x0009ffff (0xa0000) MX[B]
    	[4] -1	0	0x0000ffff - 0x0000ffff (0x1) IX[B]
    	[5] -1	0	0x00000000 - 0x00000000 (0x1) IX[B]
    (**) intel(0): Depth 24, (--) framebuffer bpp 32
    (==) intel(0): RGB weight 888
    (==) intel(0): Default visual is TrueColor
    (--) intel(0): Integrated Graphics Chipset: Intel(R) Sandybridge Mobile (GT2+)
    (**) intel(0): Relaxed fencing enabled
    (**) intel(0): Wait on SwapBuffers? enabled
    (**) intel(0): Triple buffering? enabled
    (**) intel(0): Framebuffer tiled
    (**) intel(0): Pixmaps tiled
    (**) intel(0): 3D buffers tiled
    (**) intel(0): SwapBuffers wait enabled
    (==) intel(0): video overlay key set to 0x101fe
    (II) intel(0): Output LVDS1 using monitor section Monitor[0]
    (**) intel(0): Option "PreferredMode" "1366x768"
    (--) intel(0): found backlight control interface /sys/class/backlight/acpi_video0
    (II) intel(0): Output VGA1 has no monitor section
    (II) intel(0): Output HDMI1 has no monitor section
    (II) intel(0): Output DP1 has no monitor section
    (II) intel(0): Output HDMI2 has no monitor section
    (II) intel(0): Output HDMI3 has no monitor section
    (II) intel(0): Output DP2 has no monitor section
    (II) intel(0): Output DP3 has no monitor section
    (II) intel(0): EDID vendor "CMO", prod id 5223
    (II) intel(0): Printing DDC gathered Modelines:
    (II) intel(0): Modeline "1366x768"x0.0   69.30  1366 1414 1446 1466  768 769 773 788 +hsync -vsync (47.3 kHz)
    (II) intel(0): Modeline "1366x768"x0.0   46.21  1366 1414 1446 1466  768 769 773 788 +hsync -vsync (31.5 kHz)
    (II) intel(0): Output LVDS1 connected
    (II) intel(0): Output VGA1 disconnected
    (II) intel(0): Output HDMI1 disconnected
    (II) intel(0): Output DP1 disconnected
    (II) intel(0): Output HDMI2 disconnected
    (II) intel(0): Output HDMI3 disconnected
    (II) intel(0): Output DP2 disconnected
    (II) intel(0): Output DP3 disconnected
    (II) intel(0): Using user preference for initial modes
    (II) intel(0): Output LVDS1 using initial mode 1366x768 @ 59.989197
    (II) intel(0): Kernel page flipping support detected, enabling
    (==) intel(0): Using gamma correction (1.0, 1.0, 1.0)
    (**) intel(0): Display dimensions: (309, 174) mm
    (**) intel(0): DPI set to (112, 112)
    (II) Loading sub module "fb"
    (II) LoadModule: "fb"
    (II) Loading /usr/lib64/xorg/modules//libfb.so
    (II) Module fb: vendor="X.Org Foundation"
    	compiled for 1.6.5, module version = 1.0.0
    	ABI class: X.Org ANSI C Emulation, version 0.4
    (II) Loading sub module "dri2"
    (II) LoadModule: "dri2"
    (II) Reloading /usr/lib64/xorg/modules//extensions/libdri2.so
    (==) Depth 24 pixmap format is 32 bpp
    (II) intel(0): [DRI2] Setup complete
    (II) intel(0): Allocated new frame buffer 3840x1200 stride 15360, tiled
    (II) UXA(0): Driver registered support for the following operations:
    (II)         solid
    (II)         copy
    (II)         composite (RENDER acceleration)
    (II)         put_image
    (II)         get_image
    (==) intel(0): Backing store disabled
    (==) intel(0): Silken mouse enabled
    (II) intel(0): Initializing HW Cursor
    (II) intel(0): RandR 1.2 enabled, ignore the following RandR disabled message.
    (**) Option "dpms"
    (**) intel(0): DPMS enabled
    (==) intel(0): Intel XvMC decoder enabled
    (II) intel(0): Set up textured video
    (II) intel(0): [XvMC] xvmc_vld driver initialized.
    (II) intel(0): direct rendering: DRI2 Enabled
    (WW) intel(0): Option "HASH(0x7b9f40)" is not used
    (WW) intel(0): Option "CalcAlgorithm" is not used
    (WW) intel(0): Option "PreferredMode" is not used
    (==) intel(0): hotplug detection: "enabled"
    (--) RandR disabled
    (II) Initializing built-in extension Generic Event Extension
    (II) Initializing built-in extension SHAPE
    (II) Initializing built-in extension MIT-SHM
    (II) Initializing built-in extension XInputExtension
    (II) Initializing built-in extension XTEST
    (II) Initializing built-in extension BIG-REQUESTS
    (II) Initializing built-in extension SYNC
    (II) Initializing built-in extension XKEYBOARD
    (II) Initializing built-in extension XC-APPGROUP
    (II) Initializing built-in extension XC-MISC
    (II) Initializing built-in extension SECURITY
    (II) Initializing built-in extension XINERAMA
    (II) Initializing built-in extension XFIXES
    (II) Initializing built-in extension RENDER
    (II) Initializing built-in extension RANDR
    (II) Initializing built-in extension COMPOSITE
    (II) Initializing built-in extension DAMAGE
    (II) AIGLX: enabled GLX_MESA_copy_sub_buffer
    (II) AIGLX: GLX_EXT_texture_from_pixmap backed by buffer objects
    (II) AIGLX: Loaded and initialized /usr/lib64/dri/i965_dri.so
    (II) GLX: Initialized DRI2 GL provider for screen 0
    (II) intel(0): Setting screen physical size to 309 x 174
    (II) intel(0): Allocated new frame buffer 1408x768 stride 5632, tiled
    (II) XKB: reuse xkmfile /var/lib/xkb/compiled/server-603B05CD50433F04F64C7B12280B8D7BC10853E0.xkm
    (**) Option "CoreKeyboard"
    (**) Keyboard[0]: always reports core events
    (**) Option "Protocol" "Standard"
    (**) Keyboard[0]: Protocol: Standard
    (**) Option "AutoRepeat" "500 30"
    (**) Option "XkbRules" "xfree86"
    (**) Keyboard[0]: XkbRules: "xfree86"
    (**) Option "XkbModel" "microsoftpro"
    (**) Keyboard[0]: XkbModel: "microsoftpro"
    (**) Option "XkbLayout" "it"
    (**) Keyboard[0]: XkbLayout: "it"
    (**) Option "CustomKeycodes" "off"
    (**) Keyboard[0]: CustomKeycodes disabled
    (II) XINPUT: Adding extended input device "Keyboard[0]" (type: KEYBOARD)
    (II) XKB: reuse xkmfile /var/lib/xkb/compiled/server-D7640708F4D4690184F76350C5568D1F14844DFA.xkm
    (**) Option "Protocol" "explorerps/2"
    (**) Mouse[1]: Device: "/dev/input/mice"
    (**) Mouse[1]: Protocol: "explorerps/2"
    (**) Option "CorePointer"
    (**) Mouse[1]: always reports core events
    (**) Option "Device" "/dev/input/mice"
    (**) Option "Buttons" "5"
    (==) Mouse[1]: Emulate3Buttons, Emulate3Timeout: 50
    (**) Option "ZAxisMapping" "4 5"
    (**) Mouse[1]: ZAxisMapping: buttons 4 and 5
    (**) Mouse[1]: Buttons: 9
    (**) Mouse[1]: Sensitivity: 1
    (II) XINPUT: Adding extended input device "Mouse[1]" (type: MOUSE)
    (**) Mouse[1]: (accel) keeping acceleration scheme 1
    (**) Mouse[1]: (accel) filter chain progression: 2.00
    (**) Mouse[1]: (accel) filter stage 0: 20.00 ms
    (**) Mouse[1]: (accel) set acceleration profile 0
    (II) Mouse[1]: ps2EnableDataReporting: succeeded
    (II) Synaptics touchpad driver version 1.1.3
    (--) Mouse[3] auto-dev sets device to /dev/input/event2 (waited 0 msec)
    (**) Option "Device" "/dev/input/event2"
    (II) Mouse[3]: x-axis range 1472 - 5728
    (II) Mouse[3]: y-axis range 1408 - 4916
    (II) Mouse[3]: resolution 45 x 85
    (II) Mouse[3]: pressure range 0 - 255
    (II) Mouse[3]: finger width range 0 - 15
    (II) Mouse[3]: buttons: left right double triple
    (II) Mouse[3]: bustype = 0x11
    (**) Option "SHMConfig" "on"
    (**) Option "HorizScrollDelta" "0"
    (--) Mouse[3]: touchpad found
    (**) Option "SendCoreEvents"
    (**) Mouse[3]: always reports core events
    (II) XINPUT: Adding extended input device "Mouse[3]" (type: TOUCHPAD)
    (**) Mouse[3]: (accel) keeping acceleration scheme 1
    (**) Mouse[3]: (accel) filter chain progression: 2.00
    (**) Mouse[3]: (accel) filter stage 0: 20.00 ms
    (**) Mouse[3]: (accel) set acceleration profile 0
    (--) Mouse[3] auto-dev sets device to /dev/input/event2 (waited 0 msec)
    (**) Option "Device" "/dev/input/event2"
    (--) Mouse[3]: touchpad found
    (II) config/hal: Adding input device AT Translated Set 2 keyboard
    (EE) config/hal: NewInputDeviceRequest failed (8)
    (II) config/hal: Adding input device PS/2 Generic Mouse
    (EE) config/hal: NewInputDeviceRequest failed (8)
    (II) config/hal: Adding input device Logitech Logitech USB Optical Mouse
    (EE) config/hal: NewInputDeviceRequest failed (8)
    (II) config/hal: Adding input device HP WMI hotkeys
    (EE) config/hal: NewInputDeviceRequest failed (8)
    (II) config/hal: Adding input device SynPS/2 Synaptics TouchPad
    (EE) config/hal: NewInputDeviceRequest failed (8)
    (II) config/hal: Adding input device Logitech USB Keyboard
    (EE) config/hal: NewInputDeviceRequest failed (8)
    (II) config/hal: Adding input device Logitech USB Keyboard
    (EE) config/hal: NewInputDeviceRequest failed (8)
    (II) config/hal: Adding input device Video Bus
    (EE) config/hal: NewInputDeviceRequest failed (8)
    (II) UnloadModule: "kbd"
    (II) UnloadModule: "mouse"
    (II) UnloadModule: "synaptics"
    (II) Open ACPI successful (/var/run/acpid.socket)
    (II) APM registered successfully
    (II) intel(0): [DRI2] Setup complete
    (II) intel(0): Allocated new frame buffer 1408x768 stride 5632, tiled
    (II) UXA(0): Driver registered support for the following operations:
    (II)         solid
    (II)         copy
    (II)         composite (RENDER acceleration)
    (II)         put_image
    (II)         get_image
    (II) intel(0): Initializing HW Cursor
    (II) intel(0): RandR 1.2 enabled, ignore the following RandR disabled message.
    (**) intel(0): DPMS enabled
    (==) intel(0): Intel XvMC decoder enabled
    (II) intel(0): Set up textured video
    (II) intel(0): [XvMC] xvmc_vld driver initialized.
    (II) intel(0): direct rendering: DRI2 Enabled
    (==) intel(0): hotplug detection: "enabled"
    (--) RandR disabled
    (II) AIGLX: enabled GLX_MESA_copy_sub_buffer
    (II) AIGLX: GLX_EXT_texture_from_pixmap backed by buffer objects
    (II) AIGLX: Loaded and initialized /usr/lib64/dri/i965_dri.so
    (II) GLX: Initialized DRI2 GL provider for screen 0
    (II) intel(0): Setting screen physical size to 309 x 174
    (EE) XKB: No components provided for device Virtual core keyboard
    (WW) Couldn't load XKB keymap, falling back to pre-XKB keymap
    (**) Option "CoreKeyboard"
    (**) Keyboard[0]: always reports core events
    (**) Option "Protocol" "Standard"
    (**) Keyboard[0]: Protocol: Standard
    (**) Option "AutoRepeat" "500 30"
    (**) Option "XkbRules" "xfree86"
    (**) Keyboard[0]: XkbRules: "xfree86"
    (**) Option "XkbModel" "microsoftpro"
    (**) Keyboard[0]: XkbModel: "microsoftpro"
    (**) Option "XkbLayout" "it"
    (**) Keyboard[0]: XkbLayout: "it"
    (**) Option "CustomKeycodes" "off"
    (**) Keyboard[0]: CustomKeycodes disabled
    (II) XKB: reuse xkmfile /var/lib/xkb/compiled/server-D7640708F4D4690184F76350C5568D1F14844DFA.xkm
    (**) Mouse[1]: Device: "/dev/input/mice"
    (**) Mouse[1]: Protocol: "explorerps/2"
    (**) Option "CorePointer"
    (**) Mouse[1]: always reports core events
    (**) Option "Device" "/dev/input/mice"
    (**) Option "Buttons" "5"
    (==) Mouse[1]: Emulate3Buttons, Emulate3Timeout: 50
    (**) Option "ZAxisMapping" "4 5"
    (**) Mouse[1]: ZAxisMapping: buttons 4 and 5
    (**) Mouse[1]: Buttons: 9
    (**) Mouse[1]: Sensitivity: 1
    (**) Mouse[1]: (accel) keeping acceleration scheme 1
    (**) Mouse[1]: (accel) filter chain progression: 2.00
    (**) Mouse[1]: (accel) filter stage 0: 20.00 ms
    (**) Mouse[1]: (accel) set acceleration profile 0
    (II) Mouse[1]: ps2EnableDataReporting: succeeded
    (II) Synaptics touchpad driver version 1.1.3
    (--) Mouse[3] auto-dev sets device to /dev/input/event2 (waited 0 msec)
    (**) Option "Device" "/dev/input/event2"
    (II) Mouse[3]: x-axis range 1472 - 5728
    (II) Mouse[3]: y-axis range 1408 - 4916
    (II) Mouse[3]: resolution 45 x 85
    (II) Mouse[3]: pressure range 0 - 255
    (II) Mouse[3]: finger width range 0 - 15
    (II) Mouse[3]: buttons: left right double triple
    (II) Mouse[3]: bustype = 0x11
    (**) Option "SHMConfig" "on"
    (**) Option "HorizScrollDelta" "0"
    (--) Mouse[3]: touchpad found
    (**) Option "SendCoreEvents"
    (**) Mouse[3]: always reports core events
    (**) Mouse[3]: (accel) keeping acceleration scheme 1
    (**) Mouse[3]: (accel) filter chain progression: 2.00
    (**) Mouse[3]: (accel) filter stage 0: 20.00 ms
    (**) Mouse[3]: (accel) set acceleration profile 0
    (--) Mouse[3] auto-dev sets device to /dev/input/event2 (waited 0 msec)
    (**) Option "Device" "/dev/input/event2"
    (--) Mouse[3]: touchpad found
    (II) config/hal: Adding input device AT Translated Set 2 keyboard
    (EE) config/hal: NewInputDeviceRequest failed (8)
    (II) config/hal: Adding input device PS/2 Generic Mouse
    (EE) config/hal: NewInputDeviceRequest failed (8)
    (II) config/hal: Adding input device Logitech Logitech USB Optical Mouse
    (EE) config/hal: NewInputDeviceRequest failed (8)
    (II) config/hal: Adding input device HP WMI hotkeys
    (EE) config/hal: NewInputDeviceRequest failed (8)
    (II) config/hal: Adding input device SynPS/2 Synaptics TouchPad
    (EE) config/hal: NewInputDeviceRequest failed (8)
    (II) config/hal: Adding input device Logitech USB Keyboard
    (EE) config/hal: NewInputDeviceRequest failed (8)
    (II) config/hal: Adding input device Logitech USB Keyboard
    (EE) config/hal: NewInputDeviceRequest failed (8)
    (II) config/hal: Adding input device Video Bus
    (EE) config/hal: NewInputDeviceRequest failed (8)
    (II) intel(0): EDID vendor "CMO", prod id 5223
    (II) intel(0): Printing DDC gathered Modelines:
    (II) intel(0): Modeline "1366x768"x0.0   69.30  1366 1414 1446 1466  768 769 773 788 +hsync -vsync (47.3 kHz)
    (II) intel(0): Modeline "1366x768"x0.0   46.21  1366 1414 1446 1466  768 769 773 788 +hsync -vsync (31.5 kHz)
    (II) intel(0): EDID vendor "CMO", prod id 5223
    (II) intel(0): Printing DDC gathered Modelines:
    (II) intel(0): Modeline "1366x768"x0.0   69.30  1366 1414 1446 1466  768 769 773 788 +hsync -vsync (47.3 kHz)
    (II) intel(0): Modeline "1366x768"x0.0   46.21  1366 1414 1446 1466  768 769 773 788 +hsync -vsync (31.5 kHz)
    (II) intel(0): EDID vendor "CMO", prod id 5223
    (II) intel(0): Printing DDC gathered Modelines:
    (II) intel(0): Modeline "1366x768"x0.0   69.30  1366 1414 1446 1466  768 769 773 788 +hsync -vsync (47.3 kHz)
    (II) intel(0): Modeline "1366x768"x0.0   46.21  1366 1414 1446 1466  768 769 773 788 +hsync -vsync (31.5 kHz)
    (II) intel(0): EDID vendor "CMO", prod id 5223
    (II) intel(0): Printing DDC gathered Modelines:
    (II) intel(0): Modeline "1366x768"x0.0   69.30  1366 1414 1446 1466  768 769 773 788 +hsync -vsync (47.3 kHz)
    (II) intel(0): Modeline "1366x768"x0.0   46.21  1366 1414 1446 1466  768 769 773 788 +hsync -vsync (31.5 kHz)
    (II) AIGLX: Suspending AIGLX clients for VT switch

  8. #8

    Re: X Display Failure

    I'm stumped on this I'm afraid. I can't see any errors in the Xorg log. The log shows the Intel video driver loading. You have Intel graphics card, right?

    What's the output of
    Code:
    $ /sbin/lspci -knn
    Did you install any updates since the graphics last worked? (/var/log/zypp/history shows what's been installed and when)
    If you find this post helpful and are logged into the web interface, please show your appreciation and click on the star below... thanks!

  9. #9

    Re: X Display Failure

    Hi Mike,
    Below the output of /sbin/lspci -knn , but in the /var/log/zypp/history file I can see that the 16th Dicember I installed the TeamViewer rpm package. (As you can see after the /sbin/lspci -knn output) I'm going to remove it...


    Code:
    # /sbin/lspci -knn
    00:00.0 Host bridge [0600]: Intel Corporation 2nd Generation Core Processor Family DRAM Controller [8086:0104] (rev 09)
    	Subsystem: Hewlett-Packard Company Device [103c:161c]
    00:02.0 VGA compatible controller [0300]: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0126] (rev 09)
    	Subsystem: Hewlett-Packard Company Device [103c:161c]
    	Kernel driver in use: i915
    	Kernel modules: i915
    00:16.0 Communication controller [0780]: Intel Corporation 6 Series/C200 Series Chipset Family MEI Controller #1 [8086:1c3a] (rev 04)
    	Subsystem: Hewlett-Packard Company Device [103c:161c]
    	Kernel driver in use: mei
    	Kernel modules: mei
    00:16.3 Serial controller [0700]: Intel Corporation 6 Series/C200 Series Chipset Family KT Controller [8086:1c3d] (rev 04)
    	Subsystem: Hewlett-Packard Company Device [103c:161c]
    	Kernel driver in use: serial
    00:19.0 Ethernet controller [0200]: Intel Corporation 82579LM Gigabit Network Connection [8086:1502] (rev 04)
    	Subsystem: Hewlett-Packard Company Device [103c:161c]
    	Kernel driver in use: e1000e
    	Kernel modules: e1000e
    00:1a.0 USB controller [0c03]: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2 [8086:1c2d] (rev 04)
    	Subsystem: Hewlett-Packard Company Device [103c:161c]
    	Kernel driver in use: ehci_hcd
    	Kernel modules: ehci-hcd
    00:1b.0 Audio device [0403]: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller [8086:1c20] (rev 04)
    	Subsystem: Hewlett-Packard Company Device [103c:161c]
    	Kernel driver in use: HDA Intel
    	Kernel modules: snd-hda-intel
    00:1c.0 PCI bridge [0604]: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 1 [8086:1c10] (rev b4)
    	Kernel driver in use: pcieport
    	Kernel modules: shpchp
    00:1c.1 PCI bridge [0604]: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 2 [8086:1c12] (rev b4)
    	Kernel driver in use: pcieport
    	Kernel modules: shpchp
    00:1c.2 PCI bridge [0604]: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 3 [8086:1c14] (rev b4)
    	Kernel driver in use: pcieport
    	Kernel modules: shpchp
    00:1c.3 PCI bridge [0604]: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 4 [8086:1c16] (rev b4)
    	Kernel driver in use: pcieport
    	Kernel modules: shpchp
    00:1c.7 PCI bridge [0604]: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 8 [8086:1c1e] (rev b4)
    	Kernel driver in use: pcieport
    	Kernel modules: shpchp
    00:1d.0 USB controller [0c03]: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1 [8086:1c26] (rev 04)
    	Subsystem: Hewlett-Packard Company Device [103c:161c]
    	Kernel driver in use: ehci_hcd
    	Kernel modules: ehci-hcd
    00:1f.0 ISA bridge [0601]: Intel Corporation QM67 Express Chipset Family LPC Controller [8086:1c4f] (rev 04)
    	Subsystem: Hewlett-Packard Company Device [103c:161c]
    	Kernel modules: iTCO_wdt
    00:1f.2 SATA controller [0106]: Intel Corporation 6 Series/C200 Series Chipset Family 6 port SATA AHCI Controller [8086:1c03] (rev 04)
    	Subsystem: Hewlett-Packard Company Device [103c:161c]
    	Kernel driver in use: ahci
    	Kernel modules: ahci
    23:00.0 FireWire (IEEE 1394) [0c00]: JMicron Technology Corp. IEEE 1394 Host Controller [197b:2380] (rev 30)
    	Subsystem: Hewlett-Packard Company Device [103c:161c]
    	Kernel driver in use: firewire_ohci
    	Kernel modules: firewire-ohci
    23:00.1 System peripheral [0880]: JMicron Technology Corp. SD/MMC Host Controller [197b:2392] (rev 30)
    	Subsystem: Hewlett-Packard Company Device [103c:161c]
    	Kernel driver in use: sdhci-pci
    	Kernel modules: sdhci-pci
    23:00.2 SD Host controller [0805]: JMicron Technology Corp. Standard SD Host Controller [197b:2391] (rev 30)
    	Subsystem: Hewlett-Packard Company Device [103c:161c]
    	Kernel modules: sdhci-pci
    24:00.0 Network controller [0280]: Intel Corporation Centrino Advanced-N 6205 [Taylor Peak] [8086:0085] (rev 34)
    	Subsystem: Intel Corporation Centrino Advanced-N 6205 AGN [8086:1311]
    	Kernel driver in use: iwlwifi
    	Kernel modules: iwlagn
    25:00.0 USB controller [0c03]: NEC Corporation uPD720200 USB 3.0 Host Controller [1033:0194] (rev 04)
    	Subsystem: Hewlett-Packard Company Device [103c:161c]
    	Kernel driver in use: xhci_hcd
    	Kernel modules: xhci-hcd
    Code:
    # 2014-12-16 10:10:44 teamviewer.rpm installed ok
    # Additional rpm output:
    # warning: /var/cache/zypp/packages/PK_TMP_DIR/teamviewer.rpm: Header V4 DSA signature: NOKEY, key ID 72db573c
    #
    2014-12-16 10:10:44|install|teamviewer|10.0.36281-0|i686|root@A54CC749|PK_TMP_DIR||
    2014-12-16 10:10:45|rremove|PK_TMP_DIR|

  10. #10

    Re: X Display Failure

    Quote Originally Posted by mauriB View Post
    Hi Mike,
    Below the output of /sbin/lspci -knn , but in the /var/log/zypp/history file I can see that the 16th Dicember I installed the TeamViewer rpm package. (As you can see after the /sbin/lspci -knn output) I'm going to remove it...
    I doubt it's the teamviewer package, I can't see anything in it that would mess up X configuration. Pretty much everything is in /opt/teamviewer, the pre/post install scripts on the package are innocuous.

    Interesting that the Teamviewer Linux client is actually a Windows binary plus WINE.
    If you find this post helpful and are logged into the web interface, please show your appreciation and click on the star below... thanks!

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •