I have overcome my issue when trying to start a XEN VM via a HA resource in SLES 12. It turned out to be a cluster configuration setting needing adjustment - the 'placement strategy' needed to be set to 'default' (i had it on 'balanced). I had the dual-master drbd resources running fine with the 'balanced' setting, just the VM resource would not start.

This is great, of course.

However, using XEN, I still have the issue (weather using HA VM resource or command line virsh), where the live migration still fails. Both methods return the same error, 'Migration failed: Could not unpause domain'. The result is that the VM ends up running on both nodes simultaneously.

I researched much on how libvirt should be configured for live migration and could not find anything that I have incorrectly configured. I did find that the 'tun' service should be enabled - I installed and enabled it - for the purpose of live migration and preventing simultaneous dual instances of the VM running - this, however, did not resolve the issue.

I then rebooted my 2 nodes in the normal kernel (which I had already installed KVM on) and tried the HA resource and live migration using KVM. The HA resource started the VM successfully (as per the XEN VM previously) and live migration worked perfectly (it also worked perfectly using the virsh commandline.

So, to wrap up, KVM works fine using HA and live migration and XEN does not live migrate at all - all this as tested on the exact same 2 nodes running SLES 12 with HA extension pack installed.


I guess I will be using KVM on SLES 12 for now until the XEN issues are ironed out.


However, does anyone know of a solution to this XEN VM issue running on SLES 12 with live migration set up?

Regards,
John