SUSECON
Results 1 to 6 of 6

Thread: slow storage performance - HW or DBA issue ?

Threaded View

  1. slow storage performance - HW or DBA issue ?

    OS: SLES 11 SP3
    Storage: Multipath FC SAN on raid10.

    DBA ran an I/O bond job(indexing) and complained about slow performance, as he did the similar excercise on other system(identical hardware/storage) previously and job was completed comparitively 4 hours early.

    While the job was running I got the chance to collect the iostat output and per my understanding found no bottleneck on storage/hardware level (/oracle file system is on /dev/dm-0)
    Code:
    # iostat -xk /dev/dm-0  2 6
    Linux 3.0.76-0.11-default (thltlp)      01/18/15        _x86_64_
    
    avg-cpu:  %user   %nice %system %iowait  %steal   %idle
               3.07    0.00    0.16    2.55    0.00   94.22
    
    Device:         rrqm/s   wrqm/s     r/s     w/s    rkB/s    wkB/s avgrq-sz avgqu-sz   await  svctm  %util
    dm-0            124.99     6.01  669.11   43.72 16733.30   855.89    49.35     3.22    4.52   0.82  58.52
    
    avg-cpu:  %user   %nice %system %iowait  %steal   %idle
               3.25    0.00    0.20   14.01    0.00   82.54
    
    Device:         rrqm/s   wrqm/s     r/s     w/s    rkB/s    wkB/s avgrq-sz avgqu-sz   await  svctm  %util
    dm-0             13.50     0.00 1145.50   11.50 12644.00    65.00    21.97     6.55   10.92   0.86 100.00
    
    avg-cpu:  %user   %nice %system %iowait  %steal   %idle
               3.28    0.00    0.19   12.41    0.00   84.13
    
    Device:         rrqm/s   wrqm/s     r/s     w/s    rkB/s    wkB/s avgrq-sz avgqu-sz   await  svctm  %util
    dm-0             12.00     4.00 1066.00   12.00 12580.00    57.00    23.45     5.47    6.89   0.93 100.00
    
    avg-cpu:  %user   %nice %system %iowait  %steal   %idle
               3.16    0.00    0.15   13.02    0.00   83.67
    
    Device:         rrqm/s   wrqm/s     r/s     w/s    rkB/s    wkB/s avgrq-sz avgqu-sz   await  svctm  %util
    dm-0             13.50     0.00  806.00   10.00 10008.00    49.00    24.65     4.79    4.66   1.23 100.00
    
    avg-cpu:  %user   %nice %system %iowait  %steal   %idle
               3.11    0.00    0.23   11.81    0.00   84.86
    
    Device:         rrqm/s   wrqm/s     r/s     w/s    rkB/s    wkB/s avgrq-sz avgqu-sz   await  svctm  %util
    dm-0              6.50     0.00 1144.00   10.00 12684.00    49.00    22.07     4.73    3.09   0.87 100.00
    
    avg-cpu:  %user   %nice %system %iowait  %steal   %idle
               3.10    0.00    0.11   12.01    0.00   84.78
    
    Device:         rrqm/s   wrqm/s     r/s     w/s    rkB/s    wkB/s avgrq-sz avgqu-sz   await  svctm  %util
    dm-0             13.00     0.00  882.00   12.00 11112.00    50.00    24.97     4.81    4.30   1.12 100.00


    Please guide me if there is any performance issue with hardware/storage or the DBA should check this with DB Support.
    Last edited by sharfuddin; 19-Jan-2015 at 06:04.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •