Quote Originally Posted by mikewillis View Post
Where did you notice this link?
I just realised the answer to that is probably the subject of your post: Applications -> System Tools -> Setup Your Encrypted...
However that doesn't exist on the machines I'm looking at.

I just tried encrypting a user's home directory. It seems to have worked OK, even though I was logged in as the user at the time. I didn't see any messages that flashed up and closed before I had chance to read them.

There's now a .img file in /home
$ ls -lh /home
total 215M
drwxr-xr-x 1 root root   832 Apr 14 08:37 mike
-rw------- 1 mike root 1001M Apr 14 08:46 mike.img
-rw------- 1 mike root   288 Apr 14 08:42 mike.key
/home/mike still contains all my files. So encrypting home directory has left behind the original unencrypted version. I guess that's good and bad. Good because it hasn't trashed the original so if the encryption went wrong you've not lost anything (though you should have backup anyway of course), bad because there's unencrypted versions of your files still on disk.

If I log in as mike then run mount I see
$ mount | grep mike
/dev/mapper/_dev_loop0 on /home/mike type ext3 (rw,relatime,data=ordered)
Everything that was in /home/mike has been copied to this new home directory. I was careful to specify a size for the encrypted home directory large enough to accommodate all the files in /home/mike, I don't know what happens if you specify a size smaller than the current content of the user's home directory.

If I create a new file HELLOWORLD in my home directory, then reboot, log in as root and look in /home/mike the HELLOWORLD file isn't there. If I log in as mike the HELLOWORLD file is there. Thus demonstrating that the encrypted version of mike's home directory is being used when mike logs in.

Your didn't specify SLED version but I've assumed SLED 12 since your other recent posts refer to SLED 12.