Hi everyone,

we are setting up a cloud environment and were able to install it after facing several problems. Now that we finally got all mandatory services deployed by crowbar to the control and compute node, we can log in to the OpenStack web-interface and create projects, users, images. After uploading a debian-image we tried to start our first instance based on this image.
The instance could not be started because of the message "No valid host was found, Code 500". The log files for the compute node on our admin node (/var/log/nodes/<MAC-ADDRESS-COMPUTE-NODE>.log) were saying:

May 11 10:07:07 d0c-c4-7a-06-71-f0 openstack-nova-compute[371]: Starting nova-compute..done
May 11 10:07:08 d0c-c4-7a-06-71-f0 libvirtd[1087]: End of file while reading data: Input/output error
May 11 10:07:08 d0c-c4-7a-06-71-f0 openstack-nova-compute[494]: Shutting down nova-compute..done

Obviously the required service is not abled to stay up, so the instance can not be transferred from control to admin node. Checking "nova-manage service list" shows "XXX" for nova-compute:

Binary Host Zone Status State Updated_At
nova-conductor d00-16-3e-00-20-01 internal enabled :-) 2015-05-11 15:03:25.939024
nova-compute d0c-c4-7a-06-71-f0 nova enabled XXX 2015-05-11 15:03:31.940292
nova-cert d00-16-3e-00-20-01 internal enabled :-) 2015-05-11 15:03:28.992488
nova-scheduler d00-16-3e-00-20-01 internal enabled :-) 2015-05-11 15:03:29.258377
nova-consoleauth d00-16-3e-00-20-01 internal enabled :-) 2015-05-11 15:03:29.551547

We tried reboots and some other things but nothing worked, until a co-worker changed the file /usr/lib/python2.7/site-packages/nova/virt/libvirt/driver.py, line 4882 according to this post:
https://review.openstack.org/gitweb?...f763cce8242965

We restarted the nova-compute service and the compute node changed from status "down" to "up", it is still up after a couple of hours. After that we could successfully start an instance.

I hope this information helps!

Regards,
Eugen