Hi
I have some problems with my Apache system and now my SMT is not mirroring.

When I run smt-mirror I get the above error

my SMT.conf has the entry
MirrorTo = /srv/www/vhosts/sles.pegasustech.com.au/smt

I made a backup copy of smt-mirror and changed the relevant section as follows

if(!defined $LocalBasePath || $LocalBasePath eq "" )
{
$LocalBasePath = $cfg->val("LOCAL", "MirrorTo");
print "\n >$LocalBasePath< \n";
if(!-d $LocalBasePath)
{
SMT::Utils:rintLog($LOG, $vblevel, LOG_ERROR, __("Cannot read the local base path >$LocalBasePath<"));
SMT::Utils::unLockAndExit( "smt-mirror", 1, $LOG, $vblevel );
}
}

When I run the altered file i get

>/srv/www/vhosts/sles.pegasustech.com.au/smt<
Cannot read the local base path >/srv/www/vhosts/sles.pegasustech.com.au/smt<

So I created a test program
#!/usr/bin/perl -w
#
use strict;
my $aaa="/srv/www/vhosts/sles.pegasustech.com.au/smt";

print ">$aaa< \n";

if ( !-d $aaa) {
print "NotFound \n";
}
else {
print "Found \n";
}

Running the Test Program returns:

>/srv/www/vhosts/sles.pegasustech.com.au/smt<
Found

Oh, the directory does exist owner smt:www

Why is the result different between these two ??

Thanks in advance

Mark