Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Configure telnet correctly

Hybrid View

  1. Question Configure telnet correctly

    I need telnet & i know about the secure issues... :-)

    I have installed the telnet-server & enabled the xinetd in /etc/xinetd.d/telnet. The firewall is disabled for configuring the telnet purposes.
    What have I do more? Better: how I have to install or configure right?

    I am using Suse Linux Enterprise Server 12 x64.

    Thx for a reply

  2. Re: Configure telnet correctly

    On Tue 09 Jun 2015 01:24:02 PM CDT, mrspedag2 wrote:


    I need telnet & i know about the secure issues... :-)

    I have installed the telnet-server & enabled the xinetd in
    /etc/xinetd.d/telnet. The firewall is disabled for configuring the
    telnet purposes.
    What have I do more? Better: how I have to install or configure right?

    I am using Suse Linux Enterprise Server 12 x64.

    Thx for a reply


    Hi
    Is telnet working now? If not probably start the xinetd service (SLE 12
    uses systemd/systemctl). If it is running then re-enable the firewall
    and then via YaST Firewall and allowed services on the drop down at the
    right select the telnet server and add and save.

    I would perhaps look at configuring telnet to use a non standard port
    as well for additional security.

    --
    Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 12 GNOME 3.10.1 Kernel 3.12.39-47-default
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!


  3. Re: Configure telnet correctly

    Hi,
    xinetd is running. Still not able to connect via Telnet: ... connection refused. I have still disabled the firewall. Don't know, what & where can I do more

  4. #4

    Re: Configure telnet correctly

    While we're waiting for the smart people to return to help you a bit more,
    what is the purpose of this service on a nice, new, otherwise-secure
    system? I'm really curious what could cause somebody to voluntarily use
    telnet in 2015.

    Also, have your xinetd configuration file for this thing? Seeing that may
    be interesting.


    --
    Good luck.

    If you find this post helpful and are logged into the web interface,
    show your appreciation and click on the star below...

  5. Re: Configure telnet correctly

    On Thu 11 Jun 2015 06:54:01 PM CDT, mrspedag2 wrote:


    Hi,
    xinetd is running. Still not able to connect via Telnet: ... connection
    refused. I have still disabled the firewall. Don't know, what & where
    can I do more


    Hi
    In the /etc/xinet.d/telnet file you need to set the line disable = no
    and restart xinetd service.

    By the looks you also need to configure the kerbos realm...

    --
    Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 12 GNOME 3.10.1 Kernel 3.12.39-47-default
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!


  6. Re: Configure telnet correctly

    Hi Malcolm,

    I have installed the kerberos services; same message: the remote system has refused the connection.
    /etc/xinetd.d/telnet:
    service telnet
    {
    socket_type = stream
    protocol = tcp
    wait = no
    user = root
    server = /usr/sbin/in.telnetd
    disable = no
    }

    Meanwhile I tried ssh2: try to connect via ssh2 with a user, the following message will shown:

    The server has disconnected with an error. Server message reads:
    A protocol error occurred. Change of username or service not allowed: (root,ssh-connection) -> (scm.adm,ssh-connection).

    All so confusing me...

  7. Re: Configure telnet correctly

    On Fri 12 Jun 2015 08:44:01 AM CDT, mrspedag2 wrote:


    Hi Malcolm,

    I have installed the kerberos services; same message: the remote system
    has refused the connection.
    /etc/xinetd.d/telnet:
    service telnet
    {
    socket_type = stream
    protocol = tcp
    wait = no
    user = root
    server = /usr/sbin/in.telnetd
    disable = no
    }

    Meanwhile I tried ssh2: try to connect via ssh2 with a user, the
    following message will shown:

    The server has disconnected with an error. Server message reads:
    A protocol error occurred. Change of username or service not allowed:
    (root,ssh-connection) -> (scm.adm,ssh-connection).

    All so confusing me...


    Hi
    Strange indeed, sure you don't have a mis-configure hosts file, dns
    setting sending you to the wrong machine?

    Maybe run ssh and wind up the verbosity when you connect...
    Code:
    ssh -vv user@target
    --
    Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 12 GNOME 3.10.1 Kernel 3.12.39-47-default
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!


  8. Re: Configure telnet correctly

    Hi mrspead2,

    > Don't know, what & where can I do more

    look at the logs - you should see a hint of telnetd, reported by xinetd once it receives the connection...

    Regards,
    Jens
    From the times when today's "old school" was "new school"

    If you find this post helpful and are logged into the web interface, show your appreciation and click on the star below...

  9. Re: Configure telnet correctly

    Hi,

    I didn't give up...

    Solution for the ssh connect:
    I have created an user group with the permission to use ssh. I added the required users to this group, and they may connect via ssh, now.
    Ok, I could stop from this point, now. But unresolved problems are painful, aren't they?

    I tried using telnet:
    mrbscm02:~ # telnet localhost
    Trying ::1...
    telnet: connect to address ::1: Connection refused
    Trying 127.0.0.1...
    telnet: connect to address 127.0.0.1: Connection refused
    mrbscm02:~ #

    I want to solve it....

  10. #10

    Re: Configure telnet correctly

    Quote Originally Posted by mrspedag2 View Post
    Hi,

    I didn't give up...

    Solution for the ssh connect:
    I have created an user group with the permission to use ssh. I added the required users to this group, and they may connect via ssh, now.
    Ok, I could stop from this point, now. But unresolved problems are painful, aren't they?

    I tried using telnet:
    mrbscm02:~ # telnet localhost
    Trying ::1...
    telnet: connect to address ::1: Connection refused
    Trying 127.0.0.1...
    telnet: connect to address 127.0.0.1: Connection refused
    mrbscm02:~ #

    I want to solve it....
    Your original post stated " I need telnet & i know about the secure issues... :-)" but you're now saying that you have set up ssh and "could stop from this point, now". Which suggests you don't actually need telnet at all. Do you really need telnet or can you use ssh instead? If you are able to use ssh instead of telnet then forget about telnet.
    If you find this post helpful and are logged into the web interface, please show your appreciation and click on the star below... thanks!

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •