With legacy BIOS I was able to add unattended installation files to SLES boot media by copying the DVD media to a folder, adding my unattended installation files to this folder, then creating a bootable iso image by running mkisofs:
mkisofs -r -o /tmp/<filename>.iso -b boot/x86_64/loader/isolinux.bin -c boot.cat -no-emul-boot -boot-load-size 4 -boot-info-table .

I could burn a DVD with the iso in /tmp and boot from it (and install SLES with it). This no longer works with UEFI enabled as that mkisofs cmd does not capture the efi boot loader. After reading this forum, I tried this:

mkisofs -r -o /tmp/<filename>.iso -b boot/x86_64/loader/isolinux.bin -c boot.cat -no-emul-boot -boot-load-size 4 -boot-info-table -eltorito-alt-boot -b EFI/BOOT/bootx64.efi -no-emul-boot -boot-load-size 18755 .

but that doesn't work either (UEFI +Secure Boot rejects it). I also tried using ultraiso to open the original SUSE iso, add some files, and then save it. That resulting iso won't boot either (if UEFI enabled). Anyone know how to capture both Legacy BIOS and EFI boot using mkisofs to recreate the Build media?
Could this be intentionally no longer possible - violation of security model?