touchpad & some function keys no longer working properly after sled11sp4 update

i have liked sled11sp4 very much so far, however, i have encountered a couple of problems: the function keys starting from fn+f8 to fn+f12 (and "fn+f13", which is the mute button) are not working anymore in my laptop dell xps l502x (xmodmap?). also, the touchpad is extremely sensitive and the mouse gesture on the right side of the touchpad (which it behaved like scroll up & down) is not working anymore (missing xorg.conf?).

it's worth mentioning that the function keys from fn+f2 to fn+f6 work properly. fn+f7 is assigned to nothing in this laptop.

now, when i click on the touchpad application in the control center, it gives the following error message: "gsynaptics couldn't initialize. You have to set SHMconfig 'true' in xorg.conf or xf86config to use gsynaptics".

but i can't find the xorg.conf file as i stated above. I found several similar xorg.conf.suffix files in /etc/x11/ but nothing in /etc/ for xorg.conf
within those files, inside the xorg.conf.backup file found in this folder, there was no reference to SHMconfig.

also tried 'init 3' --> 'sax2 -r -m 0=fbdev" as found in the release notes in order to manually generate a xorg.conf file; however, sax2 could not be initialized, it failed with a bunch of error messages.

i have disabled (set as 'off' in bumblebee) the discreet nvidia video card and only using the integrated intel hd3000 video card (the nvidia card consumes a lot of power and makes the laptop very hot)

these features used to work nicely in my sled11sp3. i wonder what happened.
by the way, i did not upgrade from sled11sp3 to sp4, it was a brand new installation.

any help is greatly appreciated. i use a lot of audios and videos and i utilize these keys very frequently, and the mouse gestures on my touchpad are basically out of control.

thanks in advance for your timely response.

PS: by the way, fn+F1 has never worked (this is the button to switch to presentation mode with a projector) however this is not a big deal, i don't use this laptop for presentations. Cheers.