Which version of the 'samba-list' package do you have? Mine shows
samba-libs-4.1.12-16.1.x86_64
I have the same one.

I do not have this /etc/ld.so.conf.d/samba4.conf file. Could you see
where it originates? Maybe it is left over from your previous install:
Code:
# rpm -qf /etc/ld.so.conf.d/samba4.conf
file /etc/ld.so.conf.d/samba4.conf is not owned by any package
Actually, this may indicate a problem. After upgrade to SLED12 I noticed most of a third party programs like wine, virtualbox, teamviewer, audacity, barracudavpn client, etc. that were originally installed from rpm still works (but few do not work) but do not have any associated rpm. At least yast do not find them, like they do not exist anymore. Could this be the cause of my issue?