I'm trying to register my new SLES12 VM, but I get the following error:

SUSEConnect -help
/usr/lib64/ruby/2.1.0/rubygems/dependency.rb:298:in `to_specs': Could not find 'suse-connect' (= 0.2.14) among 65 total gem(s) (Gem::LoadError)
from /usr/lib64/ruby/2.1.0/rubygems/dependency.rb:309:in `to_spec'
from /usr/lib64/ruby/2.1.0/rubygems/core_ext/kernel_gem.rb:53:in `gem'
from /usr/sbin/SUSEConnect:22:in `<main>'

If I have a look at /usr/lib64/ruby/ I see the following files:

find /usr/lib64/ruby -name \*suse\*
/usr/lib64/ruby/gems/2.1.0/cache/suse-connect-0.2.14.gem
/usr/lib64/ruby/gems/2.1.0/gems/gem2rpm-0.10.1/templates/opensuse.spec.erb
/usr/lib64/ruby/gems/2.1.0/gems/suse-connect-0.2.14
/usr/lib64/ruby/gems/2.1.0/gems/suse-connect-0.2.14/lib/suse
/usr/lib64/ruby/gems/2.1.0/gems/suse-connect-0.2.14/lib/suse.rb
/usr/lib64/ruby/gems/2.1.0/specifications/suse-connect-0.2.14.gemspec

What's wrong?
I had to install an older version of ruby in /usr/local/rvm to allow an old web application work properly. It may be possible the error is this?

Thank for any help,
Emanuele